summaryrefslogtreecommitdiff
path: root/dev-python/prettytable
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-29 10:01:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-29 10:01:01 +0100
commit8ba401288d74259a5fd8e9de5241dd57a0a73b1f (patch)
treee49dac129b06e1a0a410f4c1b91581ea02d582ff /dev-python/prettytable
parent746652e918ce7328c0cc5ffef8a79146b91ba21b (diff)
gentoo auto-resync : 29:10:2022 - 10:01:00
Diffstat (limited to 'dev-python/prettytable')
-rw-r--r--dev-python/prettytable/Manifest2
-rw-r--r--dev-python/prettytable/prettytable-3.5.0.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/prettytable/Manifest b/dev-python/prettytable/Manifest
index 7156eff2ea3d..87a2fcddc8b7 100644
--- a/dev-python/prettytable/Manifest
+++ b/dev-python/prettytable/Manifest
@@ -1,5 +1,7 @@
DIST prettytable-3.3.0.tar.gz 54305 BLAKE2B 4d131c16b6c6a0fd64aae1f9f54e286bf27b562888af56a6944d192a24c05d6138c3bdb8f298dcc060db7609d72b8d86ab9664bf6bcf43cd2105bdd433bae3cf SHA512 e190717e2ea89e8faddc7015fd5118e0d93ac5f5318641ce5960b22b4ea3740ff12c4d15812b33655252f258c96f9e848f554d1e678d39761c28025ba7772609
DIST prettytable-3.4.1.tar.gz 54395 BLAKE2B 155948a3142e5caca82e6986b51693f63a4230faf7f760b4b9738b653928cc4017835e71f5bf06c1f485b1c579c7517de1fff1424d83dd6ff629981a1d4b85ed SHA512 47a00d5d3bd6be77734abf0c6a50ac13f3d6fb72d8cc7bd2d760c860401f46ee94f766063eaeb30cf3d67c6f33fca9e3a1ae9d68af61139704bb1e23ba649ce4
+DIST prettytable-3.5.0.gh.tar.gz 45387 BLAKE2B 0ddb2c89e80c8f713c01afd4db7d5fcfa8151bcfaf7dcf07d66898b1b868ca093931829fe1b4db96c120a6eda1f84580726931dbd6d49b9870c1fc1eb0e479b9 SHA512 24ef28a42365568bf68a974afd42fcc1bfb9208e1cb75fc1b2890bc2253487afa6536e778b58e320e952ca8bf9b69193bd1293bb7615628d03765ee24c44edff
EBUILD prettytable-3.3.0.ebuild 782 BLAKE2B 3dd7611537257743e0bbabab911a2aae4be5e1efbe5f6d0e7fd60b39099a02c4b9219efb9d289398e0287eb4e1319cdd31b544e7084aeedc2017d906d66430ab SHA512 1baa694913f1cdb9fe99ef332cef406631421db174f5c97dbe5dbfb963005931e43dc5eef61fa23717b5a90831bd98dcd2092b12cba9a84595e90ba4fbdcc5e3
EBUILD prettytable-3.4.1.ebuild 782 BLAKE2B 3dd7611537257743e0bbabab911a2aae4be5e1efbe5f6d0e7fd60b39099a02c4b9219efb9d289398e0287eb4e1319cdd31b544e7084aeedc2017d906d66430ab SHA512 1baa694913f1cdb9fe99ef332cef406631421db174f5c97dbe5dbfb963005931e43dc5eef61fa23717b5a90831bd98dcd2092b12cba9a84595e90ba4fbdcc5e3
+EBUILD prettytable-3.5.0.ebuild 868 BLAKE2B 5021812ddbc4c48e4213f605dbfd28c5f4672cf97e68245bfd98605cc1ad6e35d1231515668b5e99687cf3cef671e199f72b1925943bfff974fe13fa75327146 SHA512 ed77c8a1495d14f495f2dfaa5dabc0de2f7d741c2d82c4d2d726a0183f04c39e8726f75a4af8625b5338acc037e082e2b178019fa02aec2652936a904f684b08
MISC metadata.xml 583 BLAKE2B b82fa13dd76ee47e012c03499081072c737cb63f2d23190dc3622dae1bc50ba054c7cf492a1feda7147c3a8710bd8ad509bc653e5b40f89b93ffd63da69c3f65 SHA512 e7d331df0ec72f98acc9abfc70424a619e67e559e4b02b357658e9e48efd080440a0d890ce5df2cb8cbffc53640b2068f39f803aa180bf2607d02a9df1acb5b3
diff --git a/dev-python/prettytable/prettytable-3.5.0.ebuild b/dev-python/prettytable/prettytable-3.5.0.ebuild
new file mode 100644
index 000000000000..6abe81d3e775
--- /dev/null
+++ b/dev-python/prettytable/prettytable-3.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily displaying tabular data in a visually appealing ASCII table format"
+HOMEPAGE="
+ https://github.com/jazzband/prettytable/
+ https://pypi.org/project/prettytable/
+"
+SRC_URI="
+ https://github.com/jazzband/prettytable/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}