summaryrefslogtreecommitdiff
path: root/dev-python/prometheus-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-25 09:05:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-25 09:05:36 +0100
commit070db046876f2e8d5f83cb7b380ae857d06e493a (patch)
tree81c82d9b296b94b64dd8aea6ad369ea43f40bc14 /dev-python/prometheus-client
parent4bc145ba9c79d57abcafc9b97c72bd5addd3e833 (diff)
gentoo auto-resync : 25:05:2023 - 09:05:36
Diffstat (limited to 'dev-python/prometheus-client')
-rw-r--r--dev-python/prometheus-client/Manifest5
-rw-r--r--dev-python/prometheus-client/metadata.xml13
-rw-r--r--dev-python/prometheus-client/prometheus-client-0.16.0.ebuild25
-rw-r--r--dev-python/prometheus-client/prometheus-client-0.17.0.ebuild25
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/prometheus-client/Manifest b/dev-python/prometheus-client/Manifest
new file mode 100644
index 000000000000..41b1c3ae10b2
--- /dev/null
+++ b/dev-python/prometheus-client/Manifest
@@ -0,0 +1,5 @@
+DIST prometheus_client-0.16.0.tar.gz 117546 BLAKE2B 6b4e6600b352f17620e432edd976c2d26ef71326018bd1fa81f6bf4842f1599b06b11036a3b71c641698ad3d1e2f4422812133b51a34ecc70ec0606e9ea2478c SHA512 12d22963a22511872fbd170e112a743fac02ab1a569934eef5d97f53a292281ef3f589e852f245d083d8555c5cda51c6210fe48e1211431c8fe00b47d571eaf4
+DIST prometheus_client-0.17.0.tar.gz 90650 BLAKE2B 04bc44e930c94edc9fb0ceb5cc5be71cbec23435d271ec63acacbb10b42b192170ed7f92c767a575a08a8140d9cfc28b591c49ad9af2e6d931990daba45637ba SHA512 da9a27a514dca0ae2721eaa607c5adfa86686553eebc0c4eb4323d0866d03b520de5085b8e39560df0525ef3bbbbc7996271b64136f60a427fb14fb8851e595f
+EBUILD prometheus-client-0.16.0.ebuild 579 BLAKE2B f53d39c9a9d09d8361c661a4921d8aefa977efbb9401455f70f26319e55e4b1fbada7232643a6fd602e1879cf1c6c5917caa243a1b773c6d8908f59a350da90c SHA512 d12eb90cadca85b9695757a5a0d97d4c9125a622973f076814f847faa9b1468201c154591d28d046c09ecdec60caf978f2dfa4a2b32dd7a023aab9c6326d46b5
+EBUILD prometheus-client-0.17.0.ebuild 588 BLAKE2B 1e895149c3683e802370f92b5e851a00ce0655bd519535c3d9b12ec5ec52f2eaa45725d4a4403c50f37bcbbaefd57062bf90365493b4af8936b414d701225dab SHA512 faf2bb551a83b8cffbfa1e2f13b17b0521435ad4fd8b613fe722f0c64ef27abbcc64a3b750b1cecd29cb01109a4de0cfd5819bb50be728df2be750a1b0158080
+MISC metadata.xml 409 BLAKE2B 900f1046ec87679dabe88792bfea55cdf6dbbc1f332260e5487628530a1e5b2e07a1b5776313c484ed2355c205dea165547628297da3fd3e0d9e7c352f4f7a54 SHA512 beee1bb3823aa235e8c2667b18157254335777dbf1169beaee54190d41819dd0e82c58a8ea09c4981740370d7e5463ce11d327e02bf411093dfb653a557077ff
diff --git a/dev-python/prometheus-client/metadata.xml b/dev-python/prometheus-client/metadata.xml
new file mode 100644
index 000000000000..705228750c76
--- /dev/null
+++ b/dev-python/prometheus-client/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">prometheus/client_python</remote-id>
+ <remote-id type="pypi">prometheus-client</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/prometheus-client/prometheus-client-0.16.0.ebuild b/dev-python/prometheus-client/prometheus-client-0.16.0.ebuild
new file mode 100644
index 000000000000..d13ab19b83f7
--- /dev/null
+++ b/dev-python/prometheus-client/prometheus-client-0.16.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="
+ https://github.com/prometheus/client_python/
+ https://pypi.org/project/prometheus-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/prometheus-client/prometheus-client-0.17.0.ebuild b/dev-python/prometheus-client/prometheus-client-0.17.0.ebuild
new file mode 100644
index 000000000000..587c0a11e8cc
--- /dev/null
+++ b/dev-python/prometheus-client/prometheus-client-0.17.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python client for the Prometheus monitoring system"
+HOMEPAGE="
+ https://github.com/prometheus/client_python/
+ https://pypi.org/project/prometheus-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/twisted[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest