summaryrefslogtreecommitdiff
path: root/dev-python/prompt-toolkit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 20:25:12 +0000
commitd37f8725bb68034ef10d8882fb4411a49f2f666e (patch)
tree2b530ee04815bacc1dc051db24c2727d3056b77b /dev-python/prompt-toolkit
parent171d09fa1f429aa43835c618a2c21753ad5209a4 (diff)
gentoo auto-resync : 21:02:2023 - 20:25:12
Diffstat (limited to 'dev-python/prompt-toolkit')
-rw-r--r--dev-python/prompt-toolkit/Manifest3
-rw-r--r--dev-python/prompt-toolkit/metadata.xml13
-rw-r--r--dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild25
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/prompt-toolkit/Manifest b/dev-python/prompt-toolkit/Manifest
new file mode 100644
index 000000000000..6a20408ceb87
--- /dev/null
+++ b/dev-python/prompt-toolkit/Manifest
@@ -0,0 +1,3 @@
+DIST prompt_toolkit-3.0.36.tar.gz 423863 BLAKE2B 1917ba618e4111f3d2d85f1063e3e34bc47cc1f60e1703be54cf92b98f72eb3cb3062381e16fd324953435ed67ce0711274f6d8faf735bf966283cc2201f1b65 SHA512 db77a3acb8a985b1df3d82eca7ac30fbd5e85bf3bc77f0f6da13af8064a7d4dc9d7fd57be3eabe5eecce610c8220ad493d296f2e425a8f69d62fddd1e419af1e
+EBUILD prompt-toolkit-3.0.36.ebuild 591 BLAKE2B f4e92075df9579f2caa04ae4ee4d0e6394d570d364369c0ead7125c218a64bcc7f18eeaf457957f224d354716e7d77db89e2d5978a096f86a1ad1f70503f4e2d SHA512 9baa86bb79931ccd03922044dbd3d3690852f0bd1aa791cb67214395e33d5a5dfb85885ac9e94c0b219c43caec1aaefa51e9a731e58fc375c4da7870da749478
+MISC metadata.xml 431 BLAKE2B 534336484c65b57df5e672729ff722b67445948e0485c3a62c2f7081724cb951b5157c600dc6162a3bb857c2be0f378b18670786279ff8b5cff2858588f8ebc9 SHA512 a9bf68326839069c61e70d4ef3fe304706f2543b9b91eb291566dd66f36d1abec00382ae205549a35f10dfc730f4613c5cc5c0ee4d6858538d50c4145bd3b15e
diff --git a/dev-python/prompt-toolkit/metadata.xml b/dev-python/prompt-toolkit/metadata.xml
new file mode 100644
index 000000000000..e67522584f55
--- /dev/null
+++ b/dev-python/prompt-toolkit/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">prompt-toolkit</remote-id>
+ <remote-id type="github">prompt-toolkit/python-prompt-toolkit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild b/dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild
new file mode 100644
index 000000000000..40c5d051dccb
--- /dev/null
+++ b/dev-python/prompt-toolkit/prompt-toolkit-3.0.36.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="
+ https://pypi.org/project/prompt-toolkit/
+ https://github.com/prompt-toolkit/python-prompt-toolkit/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest