summaryrefslogtreecommitdiff
path: root/dev-python/proto-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-14 12:27:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-14 12:27:14 +0100
commitf7adcd4ee556b2c3a420239c13fb74113d791f6a (patch)
tree1cc566bbd03612996262177e95152bdda507cca9 /dev-python/proto-plus
parent482a48c0e1675b1e92663b8b5222bb7261aa7956 (diff)
gentoo auto-resync : 14:07:2024 - 12:27:13
Diffstat (limited to 'dev-python/proto-plus')
-rw-r--r--dev-python/proto-plus/Manifest2
-rw-r--r--dev-python/proto-plus/proto-plus-1.24.0-r1.ebuild (renamed from dev-python/proto-plus/proto-plus-1.24.0.ebuild)9
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/proto-plus/Manifest b/dev-python/proto-plus/Manifest
index a470e1a4da8e..1429d858caf1 100644
--- a/dev-python/proto-plus/Manifest
+++ b/dev-python/proto-plus/Manifest
@@ -1,3 +1,3 @@
DIST proto-plus-python-1.24.0.gh.tar.gz 100401 BLAKE2B 29094738e9c84559b8b51b078ecb059e7475c5c6e9392f23925c6df264efebd22c191c5b593fc659aabb20ce9cb0d93cde9df28b0b40aac4bbc80e075a95ec24 SHA512 3995df0a7df60a9a5c9325c29456f73d8482ae3d765f9553e5633b8d0ae0869c6fe3cd60e780f8fcd49d04470205abf621bc56c20d64252b76d51c19ff283372
-EBUILD proto-plus-1.24.0.ebuild 888 BLAKE2B 2e0622a8ff3fd6d404d5f29b444fe71f75f3b84ff4e0b6cc6661b8fd324cf49c032618e5cfb0bbbe26558f2aa3168823fce417f6c5dd17c193c11f4436a06ef1 SHA512 de1cd88ff2d943a348b4be0ddaf1b46db2aeb168cc9d1c1e8479d6d474eb18624a5664d2cd3eab55e759d7fa5fce89ceac4b80744582d8e626203c1d5ac00ab2
+EBUILD proto-plus-1.24.0-r1.ebuild 959 BLAKE2B eababfb0ca6e48b06469745628aaac9d1648184c644ccb4f26c10eabce36e8f5db06b2f18b7df58718337f3ef0917e331a526a27a54bf9206ef7dcd390e378a9 SHA512 62a754a229d3171f85598a4ebfe399090611092c90be7793c315e95719dc7c0f201897275f88f8924d8c33fddb396c7b9154a9aa04619c5e220819871b57635d
MISC metadata.xml 447 BLAKE2B d440be836b8a2823ab3beb7f76cbe7ff3f027ec512dff3f7d920eefea3f18329e1aa910ca16e006b1424cbd780f3fad80b8ccdc632c08ade651afd815369e9d0 SHA512 d64b8d2eeac9916ec2faab3b038082155e46e8c379ce06d7f554de763318539fa9040d15f90a3a95f337937c90f4b4042f51b1ea1cd11727e5fd971a0af5280c
diff --git a/dev-python/proto-plus/proto-plus-1.24.0.ebuild b/dev-python/proto-plus/proto-plus-1.24.0-r1.ebuild
index e71f9a45d8dc..8a5dedc2161a 100644
--- a/dev-python/proto-plus/proto-plus-1.24.0.ebuild
+++ b/dev-python/proto-plus/proto-plus-1.24.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -25,7 +25,7 @@ SLOT="0"
KEYWORDS="amd64 arm64 x86"
RDEPEND="
- <dev-python/protobuf-python-5[${PYTHON_USEDEP}]
+ <dev-python/protobuf-python-6[${PYTHON_USEDEP}]
>=dev-python/protobuf-python-3.19.0[${PYTHON_USEDEP}]
"
BDEPEND="
@@ -38,3 +38,8 @@ BDEPEND="
distutils_enable_tests pytest
distutils_enable_sphinx docs \
dev-python/sphinx-rtd-theme
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}