summaryrefslogtreecommitdiff
path: root/dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild')
-rw-r--r--dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild b/dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild
deleted file mode 100644
index 02e35f92b514..000000000000
--- a/dev-python/protobuf-python/protobuf-python-3.5.1.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-# pypy fails tests; pypy3 fails even running tests
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Google's Protocol Buffers - Python bindings"
-HOMEPAGE="https://developers.google.com/protocol-buffers/ https://github.com/google/protobuf"
-SRC_URI="https://github.com/google/protobuf/archive/v${PV}.tar.gz -> protobuf-${PV}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/15"
-KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~sh ~sparc x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos"
-IUSE=""
-
-DEPEND="${PYTHON_DEPS}
- ~dev-libs/protobuf-${PV}
- dev-python/namespace-google[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- !<dev-libs/protobuf-3[python(-)]"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/protobuf-${PV}/python"
-
-python_configure_all() {
- mydistutilsargs=(--cpp_implementation)
-}
-
-python_compile() {
- python_is_python3 || local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${D}" -name "*.pth" -delete || die
-}