summaryrefslogtreecommitdiff
path: root/dev-python/pslab/pslab-2.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-01 21:50:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-01 21:50:29 +0000
commitf4271cea898f88d5785d4a92396a24e916ac301f (patch)
tree6cec9449f18dbf6a5172b553163d441d0ac83443 /dev-python/pslab/pslab-2.5.0.ebuild
parente590456a8f7fef7ac4410bcf8f1e1486848e0243 (diff)
gentoo auto-resync : 01:11:2023 - 21:50:29
Diffstat (limited to 'dev-python/pslab/pslab-2.5.0.ebuild')
-rw-r--r--dev-python/pslab/pslab-2.5.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pslab/pslab-2.5.0.ebuild b/dev-python/pslab/pslab-2.5.0.ebuild
new file mode 100644
index 000000000000..d5f734959f53
--- /dev/null
+++ b/dev-python/pslab/pslab-2.5.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=pslab-python-${PV}
+DESCRIPTION="Python library for communicating with Pocket Science Lab"
+HOMEPAGE="
+ https://pslab.io/
+ https://github.com/fossasia/pslab-python/
+ https://pypi.org/project/pslab/
+"
+SRC_URI="
+ https://github.com/fossasia/pslab-python/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64"
+
+RDEPEND="
+ >=dev-python/numpy-1.16.3[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3.4[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.0-ad9833_sys_version.patch
+)
+
+EPYTEST_DESELECT=(
+ # Flaky in 2.5.0
+ tests/test_logic_analyzer.py::test_stop
+)
+
+distutils_enable_sphinx docs dev-python/recommonmark
+distutils_enable_tests pytest