summaryrefslogtreecommitdiff
path: root/dev-python/psutil/psutil-5.9.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 20:57:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 20:57:17 +0000
commit9bc9c4dcc38dc560cff8e5d083d1e5f282ddde98 (patch)
treeaebfd3698cdc5ed079dbfd553063a19b4662965d /dev-python/psutil/psutil-5.9.1.ebuild
parentcc2c9e975285d6fb1be1b71d18ba4cca7991b921 (diff)
gentoo auto-resync : 02:12:2022 - 20:57:16
Diffstat (limited to 'dev-python/psutil/psutil-5.9.1.ebuild')
-rw-r--r--dev-python/psutil/psutil-5.9.1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/psutil/psutil-5.9.1.ebuild b/dev-python/psutil/psutil-5.9.1.ebuild
deleted file mode 100644
index f47166770945..000000000000
--- a/dev-python/psutil/psutil-5.9.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-TEST_PATCH=psutil-5.9.1-tests-r2.patch
-DESCRIPTION="Retrieve information on running processes and system utilization"
-HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.org/project/psutil/"
-SRC_URI="
- mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://dev.gentoo.org/~mgorny/dist/${TEST_PATCH}.xz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${WORKDIR}/${TEST_PATCH}"
-)
-
-python_test() {
- # Since we are running in an environment a bit similar to CI,
- # let's skip the tests that are disabled for CI
- local -x TRAVIS=1
- local -x APPVEYOR=1
- local -x GITHUB_ACTIONS=1
- local -x GENTOO_TESTING=1
- "${EPYTHON}" psutil/tests/runner.py ||
- die "tests failed with ${EPYTHON}"
-}
-
-python_compile() {
- # Force -j1 to avoid .o linking race conditions
- local MAKEOPTS=-j1
- distutils-r1_python_compile
-}