summaryrefslogtreecommitdiff
path: root/dev-python/psutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/psutil
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/psutil')
-rw-r--r--dev-python/psutil/Manifest1
-rw-r--r--dev-python/psutil/files/psutil-5.6.7-tests.patch96
2 files changed, 0 insertions, 97 deletions
diff --git a/dev-python/psutil/Manifest b/dev-python/psutil/Manifest
index ef49e69c8db7..cff75861d33a 100644
--- a/dev-python/psutil/Manifest
+++ b/dev-python/psutil/Manifest
@@ -1,4 +1,3 @@
-AUX psutil-5.6.7-tests.patch 4286 BLAKE2B c0170138af6e1dac482f4c3589c2311186916a4a6150fa8679df01bba7fe99925f97bdaab61cac7ffa19341ea33c7a68260d644fea09a4774b795e813e12c4a4 SHA512 e33a7d375b72b3d43169adb493d8ad0684a2ce88159fdeb2e92ed966b2de1a6381a023f2e226b8d91194c66eeee4ce2b936cc08a9a84152a7119fecd8679723e
AUX psutil-5.7.0-tests.patch 6018 BLAKE2B ac419a11d5caabd4184ece7a1b969e23125c122fe9a52277a7bc4af8006818b2328507e929584b464aa9ff94521c4d882819c45719dc4fb387a24c7171d5caba SHA512 3b8c901c101c56be207b008437fb0aa2f6095986e9dbdfb3f0ca5f3417ec2ee3a120d9b66f091ed9ac697d80bc17e2eb215b57bbde5b093b5b3b64ca4dae4b3b
DIST psutil-5.7.0.tar.gz 449628 BLAKE2B 3bd07a0a2f95a539910fa1cef92e72d168c3ee7a495c0defd3fad307d96448d81182b7ccc5e4388d6726495a18df26b076e27b3cbf57096a5c3c8326c00f2dea SHA512 8cee64ab396dae79866e961aeabdb9a4174e1339bcd5c0a35f23fee97ca2a61c0cb08f7152d7e0db90c387400c5c6fb3da2dd2124ce9bf97dfffe6f3b4967981
EBUILD psutil-5.7.0.ebuild 1295 BLAKE2B ac185c61234ac07cb4fa62d8afcd4546dd7eb882a0c96928ea4c64c743519f7f2f589547b849dbda6998f0c8869466cbcb82591f2fee66eb69546fa9f1475c17 SHA512 27ebe9f0471435c11e987f6b7a67ea627882faa0f379a3b2b6a493421a39b11ccf2fd3ffb21a6e637f73599be3f3616e31b6d39472d41aff6b3cd9d20e516310
diff --git a/dev-python/psutil/files/psutil-5.6.7-tests.patch b/dev-python/psutil/files/psutil-5.6.7-tests.patch
deleted file mode 100644
index 3e6ec254c19d..000000000000
--- a/dev-python/psutil/files/psutil-5.6.7-tests.patch
+++ /dev/null
@@ -1,96 +0,0 @@
-diff -dupr a/psutil/_pslinux.py b/psutil/_pslinux.py
---- a/psutil/_pslinux.py 2019-11-21 17:23:01.000000000 +0100
-+++ b/psutil/_pslinux.py 2019-11-27 12:56:11.491875281 +0100
-@@ -1108,7 +1108,7 @@ def disk_io_counters(perdisk=False):
- fields = f.read().strip().split()
- name = os.path.basename(root)
- (reads, reads_merged, rbytes, rtime, writes, writes_merged,
-- wbytes, wtime, _, busy_time, _) = map(int, fields)
-+ wbytes, wtime, _, busy_time, _) = map(int, fields[:11])
- yield (name, reads, writes, rbytes, wbytes, rtime,
- wtime, reads_merged, writes_merged, busy_time)
-
-diff -dupr a/psutil/tests/test_contracts.py b/psutil/tests/test_contracts.py
---- a/psutil/tests/test_contracts.py 2019-06-20 08:10:28.000000000 +0200
-+++ b/psutil/tests/test_contracts.py 2019-11-27 12:56:11.492875227 +0100
-@@ -174,6 +174,7 @@ class TestAvailability(unittest.TestCase
-
- class TestDeprecations(unittest.TestCase):
-
-+ @unittest.skip("broken with newer deps")
- def test_memory_info_ex(self):
- with warnings.catch_warnings(record=True) as ws:
- psutil.Process().memory_info_ex()
-diff -dupr a/psutil/tests/test_linux.py b/psutil/tests/test_linux.py
---- a/psutil/tests/test_linux.py 2019-11-21 17:23:25.000000000 +0100
-+++ b/psutil/tests/test_linux.py 2019-11-27 13:18:19.715499797 +0100
-@@ -17,6 +17,7 @@ import re
- import shutil
- import socket
- import struct
-+import sys
- import tempfile
- import textwrap
- import time
-@@ -380,6 +381,8 @@ class TestSystemVirtualMemory(unittest.T
- ret = psutil.virtual_memory()
- assert m.called
- self.assertEqual(ret.available, 2057400 * 1024 + 4818144 * 1024)
-+ if sys.version_info < (3,):
-+ return
- w = ws[0]
- self.assertIn(
- "inactive memory stats couldn't be determined", str(w.message))
-@@ -410,6 +413,8 @@ class TestSystemVirtualMemory(unittest.T
- ret = psutil.virtual_memory()
- self.assertEqual(
- ret.available, 2057400 * 1024 + 4818144 * 1024)
-+ if sys.version_info < (3,):
-+ return
- w = ws[0]
- self.assertIn(
- "inactive memory stats couldn't be determined",
-@@ -878,7 +883,7 @@ class TestLoadAvg(unittest.TestCase):
- # =====================================================================
-
-
--@unittest.skipIf(not LINUX, "LINUX only")
-+@unittest.skip('very fragile, broken with new ipaddress')
- class TestSystemNetIfAddrs(unittest.TestCase):
-
- def test_ips(self):
-@@ -1363,6 +1368,7 @@ class TestMisc(unittest.TestCase):
- psutil.PROCFS_PATH = "/proc"
- os.rmdir(tdir)
-
-+ @unittest.skip('fails on Gentoo')
- def test_issue_687(self):
- # In case of thread ID:
- # - pid_exists() is supposed to return False
-@@ -2090,6 +2096,7 @@ class TestProcessAgainstStatus(unittest.
- value = self.read_status_file("nonvoluntary_ctxt_switches:")
- self.assertEqual(self.proc.num_ctx_switches().involuntary, value)
-
-+ @unittest.skip('fails on Gentoo')
- def test_cpu_affinity(self):
- value = self.read_status_file("Cpus_allowed_list:")
- if '-' in str(value):
-diff -dupr a/psutil/tests/test_process.py b/psutil/tests/test_process.py
---- a/psutil/tests/test_process.py 2019-11-22 12:37:20.000000000 +0100
-+++ b/psutil/tests/test_process.py 2019-11-27 13:07:36.966525513 +0100
-@@ -351,6 +351,7 @@ class TestProcess(unittest.TestCase):
- self.assertGreaterEqual(io2[i], 0)
- self.assertGreaterEqual(io2[i], 0)
-
-+ @unittest.skip('fails if builder is ioniced already')
- @unittest.skipIf(not HAS_IONICE, "not supported")
- @unittest.skipIf(not LINUX, "linux only")
- def test_ionice_linux(self):
-@@ -1486,6 +1487,7 @@ class TestProcess(unittest.TestCase):
- d2 = clean_dict(os.environ.copy())
- self.assertEqual(d1, d2)
-
-+ @unittest.skip("broken by Gentoo sandbox magic")
- @unittest.skipIf(not HAS_ENVIRON, "not supported")
- @unittest.skipIf(not POSIX, "POSIX only")
- def test_weird_environ(self):