summaryrefslogtreecommitdiff
path: root/dev-python/psycopg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-17 17:57:35 +0100
commit7932d472a02d4c016ff7dff4b7a5479ab9d1883d (patch)
treed07709230f82777cae6ba7dab35aee31896060fb /dev-python/psycopg
parentd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (diff)
gentoo resync : 17.06.2021
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/Manifest4
-rw-r--r--dev-python/psycopg/psycopg-2.9.1.ebuild55
-rw-r--r--dev-python/psycopg/psycopg-2.9.ebuild55
3 files changed, 114 insertions, 0 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index 95cc08a3b42c..972128ca0a0b 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -1,3 +1,7 @@
DIST psycopg2-2.8.6.tar.gz 383797 BLAKE2B da0e3f1e143c51c940ba1f51d3e457b492d880ab71267dacd4747444bc767711ccd6c2f54d9e10ce5ad8fae0c3206fb4b6199f267e9bbaf12eb654227f59c2b0 SHA512 1e1d5d8755c6d1a153d84210bf29902afafe853659d709e13abc6bc5772def13779d2394690af1c544384c9c607edc0fe5cf2763244fb346febf9a9e0032b45f
+DIST psycopg2-2.9.1.tar.gz 379972 BLAKE2B 89a05f0f3e2f426848641bdf07bee1846a5512dd248d7e4eb4723dbc4f7775b00d142217a5cc59e126eeae8e672173b63de3b1152e3bf14dfaccf5fe7149c88d SHA512 478eaeaad98e4521424a0a48d5f0fdba934bb3b682ba111cc37b833cd3c953ad5fbe2a2071d3a9b95c6a447e95de88887ceda5143b63a08703c388f96dd9b4ad
+DIST psycopg2-2.9.tar.gz 379805 BLAKE2B 4e34b9dc28d0922ae9e9f75dd734b961915a032eba0c4b5ea9c4fe82bff4d5d230b37b0efdb25b8423177fdd7e98e69d0ed6ae0eccd731dca212845966b9c0ac SHA512 9787d0d3bb163815a452139bc3fbde93c767431b3e31c77dd534b6a476d1c09a51e2503b0420ac7a3753ef7fa64c13e2643f4bf4aeaeb60f15ea4eefc3538bfa
EBUILD psycopg-2.8.6-r1.ebuild 1313 BLAKE2B dbdf3b3a72aa22bdc1d55c9a6b8f67e706a9d13d9e43c0c09bae8a735eb999b19f262d104aaa9196c6189ed5ecebcafbce49f6499e9632d7f56b4d73c48453f3 SHA512 db57102c60158abf196eef91391c3a37a02a92fc6ffb79c57aaeaafa1b771938a1a3b1d048fe6130e9fab326b9a7d46de605090fdca09025baae051bcbd8f7cd
+EBUILD psycopg-2.9.1.ebuild 1320 BLAKE2B 979571fb982c3f10bc2e372ca057f58dd5853c548b5f0c6f323fc21130bd28a0f63efa73185401b104ef7c7ecab9a02d6b1031cdb21a94d6efa6e77fc3e7b358 SHA512 80df76f557598a869ae34a7f917863de7c93ce1a66dc4202fa76eddf360360019f45e98cdd5e7e7b3029201d41602f5bb8f502c4644825bf5b2f87847e419e92
+EBUILD psycopg-2.9.ebuild 1320 BLAKE2B 979571fb982c3f10bc2e372ca057f58dd5853c548b5f0c6f323fc21130bd28a0f63efa73185401b104ef7c7ecab9a02d6b1031cdb21a94d6efa6e77fc3e7b358 SHA512 80df76f557598a869ae34a7f917863de7c93ce1a66dc4202fa76eddf360360019f45e98cdd5e7e7b3029201d41602f5bb8f502c4644825bf5b2f87847e419e92
MISC metadata.xml 321 BLAKE2B aff48bec04e34b92668aa18214d86ddbedef2376eeced4815118d35eebfb8e6af87234a9470828f465626f7d9ed56fe0fcb8f078c23945371248136533651ad3 SHA512 358b751b3a65f64ab5468bcf4022315f7069a2fb60709c2bb12ac02577866a3ff24ab2dd69577052070cf010a51428cb3ec385ca7cfe48640f4dd25ae478a966
diff --git a/dev-python/psycopg/psycopg-2.9.1.ebuild b/dev-python/psycopg/psycopg-2.9.1.ebuild
new file mode 100644
index 000000000000..7a7e34f73507
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.9.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="https://www.psycopg.org https://pypi.org/project/psycopg2/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-db/postgresql-8.1:*"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( >=dev-db/postgresql-8.1[server] )"
+
+python_prepare_all() {
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ initdb -D "${T}"/pgsql || die
+ # TODO: random port
+ pg_ctl -w -D "${T}"/pgsql start \
+ -o "-h '' -k '${T}'" || die
+ createdb -h "${T}" psycopg2_test || die
+
+ local -x PSYCOPG2_TESTDB_HOST="${T}"
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${T}"/pgsql stop || die
+}
+
+python_test() {
+ "${EPYTHON}" -c "
+import tests
+tests.unittest.main(defaultTest='tests.test_suite')
+" --verbose || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/psycopg/psycopg-2.9.ebuild b/dev-python/psycopg/psycopg-2.9.ebuild
new file mode 100644
index 000000000000..7a7e34f73507
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="${PN}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="https://www.psycopg.org https://pypi.org/project/psycopg2/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-db/postgresql-8.1:*"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( >=dev-db/postgresql-8.1[server] )"
+
+python_prepare_all() {
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ initdb -D "${T}"/pgsql || die
+ # TODO: random port
+ pg_ctl -w -D "${T}"/pgsql start \
+ -o "-h '' -k '${T}'" || die
+ createdb -h "${T}" psycopg2_test || die
+
+ local -x PSYCOPG2_TESTDB_HOST="${T}"
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${T}"/pgsql stop || die
+}
+
+python_test() {
+ "${EPYTHON}" -c "
+import tests
+tests.unittest.main(defaultTest='tests.test_suite')
+" --verbose || die "Tests fail with ${EPYTHON}"
+}