summaryrefslogtreecommitdiff
path: root/dev-python/pulsectl-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-02 22:56:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-02 22:56:13 +0000
commit3652885475bb4bf8de9f4f8e06553d5dbd4dd03d (patch)
tree50643bb9e9c6a0980edbdd0a6e1431f3af997328 /dev-python/pulsectl-asyncio
parentd602f48b0029adc0d2ad1fceed902419909e98ac (diff)
gentoo auto-resync : 02:12:2023 - 22:56:13
Diffstat (limited to 'dev-python/pulsectl-asyncio')
-rw-r--r--dev-python/pulsectl-asyncio/Manifest3
-rw-r--r--dev-python/pulsectl-asyncio/metadata.xml12
-rw-r--r--dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild41
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pulsectl-asyncio/Manifest b/dev-python/pulsectl-asyncio/Manifest
new file mode 100644
index 000000000000..591dbd75976a
--- /dev/null
+++ b/dev-python/pulsectl-asyncio/Manifest
@@ -0,0 +1,3 @@
+DIST pulsectl-asyncio-1.1.1.gh.tar.gz 19425 BLAKE2B c950dc0e003c6795fba0b122ed9b5e3c0bb61adb1a26901f467e508ff3def64bc7c0a25e4250decbbd55aedd66ef5b030ced004e797a94ee0a5988043cd7dedb SHA512 b495295ee13d54e136cd70daaf3675239aa96faa284bd2ad0d21496821ee818f67ebbe83269a4201ea0bee99b5b2b78be3945909e1b2519078bc38c2529734bf
+EBUILD pulsectl-asyncio-1.1.1.ebuild 818 BLAKE2B 77a7359e9e0f5abf71a12e672e3a783bc1679a91825ac472aa3576aa85f84514419c499568dec690141cd9db331d3cab8e4b2c81e19db11d648bb15c9d29e012 SHA512 5e933ca5b6d65a3947903b1a180728b7b0b785fc29043d08fc2de6024cc6ff67e3ac1b5f5ed5b58f568c2bffb79750a7955a981d5b20689bb30a8a2acf2200bf
+MISC metadata.xml 386 BLAKE2B 146d1d23a6622335b70d3e29d735aea6db1b2c6575678a308c8e4c83e52250bef36cfd6965cd1a77d5fd7dde89faa8c6cf6f024d7c6b83b95b2fb6259dafb2de SHA512 23c46c37c1a2a086e8e7ac67f9d8d8922b4f0b595dcf7cc2a6acddd187055beb3c96dac212f3ee749c20095e10acbab5e56e859122c62623065b04c4b2745f41
diff --git a/dev-python/pulsectl-asyncio/metadata.xml b/dev-python/pulsectl-asyncio/metadata.xml
new file mode 100644
index 000000000000..798c499d03bf
--- /dev/null
+++ b/dev-python/pulsectl-asyncio/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">mhthies/pulsectl-asyncio</remote-id>
+ <remote-id type="pypi">pulsectl-asyncio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild
new file mode 100644
index 000000000000..a0217de9e234
--- /dev/null
+++ b/dev-python/pulsectl-asyncio/pulsectl-asyncio-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asyncio frontend for pulsectl, Python bindings of libpulse"
+HOMEPAGE="
+ https://github.com/mhthies/pulsectl-asyncio/
+ https://pypi.org/project/pulsectl-asyncio/
+"
+# sdist is missing examples that are used in tests
+SRC_URI="
+ https://github.com/mhthies/pulsectl-asyncio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pulsectl-23.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ media-sound/pulseaudio-daemon
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e 's:,<=[0-9.]*::' setup.cfg || die
+ distutils-r1_src_prepare
+}