summaryrefslogtreecommitdiff
path: root/dev-python/pure-sasl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/pure-sasl
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/pure-sasl')
-rw-r--r--dev-python/pure-sasl/Manifest3
-rw-r--r--dev-python/pure-sasl/metadata.xml7
-rw-r--r--dev-python/pure-sasl/pure-sasl-0.6.1.ebuild32
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pure-sasl/Manifest b/dev-python/pure-sasl/Manifest
new file mode 100644
index 000000000000..6f9e82567866
--- /dev/null
+++ b/dev-python/pure-sasl/Manifest
@@ -0,0 +1,3 @@
+DIST pure-sasl-0.6.1.tar.gz 11553 BLAKE2B 17a3728e23b04cfcebd967ec4e40ab40ae72ebd18325579dfac52dbeac58ebee6e467f32a8030214cd976b2ae96e446afbc853c3e4233a61fa149d2910b1ecfc SHA512 f0e34fba460b03fb2348871859f79a21ac27df4be8b125a1652891efacd428a560673f42dff0993e87a3d80439f182e3a6e07b7c968cbfa3c86311c1592822a2
+EBUILD pure-sasl-0.6.1.ebuild 742 BLAKE2B 75724320cdb833e5f95b0d3f27133f9083fe36e6a997079d95127beb6ad4905c7e73ac7399d10b6133045dde60214514bd361d382a99474ad4be41109aa9e28a SHA512 583304bc522b7384b64cb3f3ea48225ee3490e370d3494b861c890136531753b5b790dfe17ab7b80e1514996bf8b5416a003b0d7abdc62a5682e29bb07a7f85b
+MISC metadata.xml 222 BLAKE2B 627c0e9a843219968eef5f67d4a3656240cc8795a1fe885983efab35f57ec02cff5f28533c665c77e1391de3c7d2e1d7025aff9f82213e38f4c5c0e6b504c11c SHA512 b9b20f913c2b6bc8ec843d5d46a97ca2d847ccadd4dcadf7b68a60535e44b721541c72cc74b17c55fe21161a1dcfbc86a3d08e58659a8c431b574729fe87607d
diff --git a/dev-python/pure-sasl/metadata.xml b/dev-python/pure-sasl/metadata.xml
new file mode 100644
index 000000000000..3743220e59f3
--- /dev/null
+++ b/dev-python/pure-sasl/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pure-sasl/pure-sasl-0.6.1.ebuild b/dev-python/pure-sasl/pure-sasl-0.6.1.ebuild
new file mode 100644
index 000000000000..1aec7ab83c2f
--- /dev/null
+++ b/dev-python/pure-sasl/pure-sasl-0.6.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019 Sony Interactive Entertainment Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="High-level SASL client written in pure Python"
+HOMEPAGE="https://github.com/thobbs/pure-sasl"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep dev-python/unittest2 'python2*')
+ )"
+
+# tests aren't in dist tarball
+RESTRICT="test"
+
+python_test() {
+ nosetests -v || die
+}