summaryrefslogtreecommitdiff
path: root/dev-python/puremagic/puremagic-1.27.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-09 11:04:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-09 11:04:53 +0100
commit43297a4ed0a3760bbdd0b8c286b779f174ca5368 (patch)
tree15b92efd455b5d5eb0ef8a4af4f5f24572c4b46b /dev-python/puremagic/puremagic-1.27.ebuild
parent14866757225815b9374acfc8453518951e0f910d (diff)
gentoo auto-resync : 09:08:2024 - 11:04:52
Diffstat (limited to 'dev-python/puremagic/puremagic-1.27.ebuild')
-rw-r--r--dev-python/puremagic/puremagic-1.27.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/puremagic/puremagic-1.27.ebuild b/dev-python/puremagic/puremagic-1.27.ebuild
new file mode 100644
index 000000000000..7a5fd34c2d27
--- /dev/null
+++ b/dev-python/puremagic/puremagic-1.27.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python implementation of magic file detection"
+HOMEPAGE="
+ https://github.com/cdgriffith/puremagic/
+ https://pypi.org/project/puremagic/
+"
+SRC_URI="
+ https://github.com/cdgriffith/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( CHANGELOG.md README.rst )
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}