summaryrefslogtreecommitdiff
path: root/dev-python/pxml/pxml-0.2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pxml/pxml-0.2.12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pxml/pxml-0.2.12.ebuild')
-rw-r--r--dev-python/pxml/pxml-0.2.12.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pxml/pxml-0.2.12.ebuild b/dev-python/pxml/pxml-0.2.12.ebuild
new file mode 100644
index 000000000000..f9b96c5fc69b
--- /dev/null
+++ b/dev-python/pxml/pxml-0.2.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A python library and command-line tool to "prettify" and colorize XML"
+HOMEPAGE="https://pypi.python.org/pypi/pxml https://github.com/metagriffin/pxml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/blessings-1.5[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}