summaryrefslogtreecommitdiff
path: root/dev-python/py-ubjson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/py-ubjson
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/py-ubjson')
-rw-r--r--dev-python/py-ubjson/Manifest4
-rw-r--r--dev-python/py-ubjson/metadata.xml24
-rw-r--r--dev-python/py-ubjson/py-ubjson-0.9.0.ebuild19
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/py-ubjson/Manifest b/dev-python/py-ubjson/Manifest
new file mode 100644
index 000000000000..2bc2d815c3bb
--- /dev/null
+++ b/dev-python/py-ubjson/Manifest
@@ -0,0 +1,4 @@
+DIST py-ubjson-0.9.0.tar.gz 43338 SHA256 b405daaa82acdf5989207e1e5ff6865ef7d23bf450513a6d90a1ab64c75bdcf8 SHA512 d9f061e548405d16a22d235f487740b3d4abeab8b555f9684b632cdb5e2f655ba8413a207230f90e7f3f352fa3289b16bb9a56b623c0cc5fe02f61778a8f78a2 WHIRLPOOL 31bac81ba2befb3be62fbddfca270f83a34d7636f0a85ab8d7c40836020665b14aa4e03bf61c231983eebc58c3fb45b524b7a748a06f2dfbcad6ddd2002d8663
+EBUILD py-ubjson-0.9.0.ebuild 469 SHA256 94aa67ede658f738fc2fd823f9aae248d1761d5fa48f94513c9ad9894ac235ca SHA512 61c3ac45c29c47a3e452d8f3ec2e2770d1c1941f9359860f23c9e4af9b58b14dec959dd37759c83eacb12783165cc45b5fab545bb867fd951bed2d2f98613641 WHIRLPOOL 83863c043d8b17d5f66cf0ee6adf163aefc93f7702b907a278098dfe4d904783d4f3e7ed7a1aa42bcbe7877af1bbf1e428d4fb0e091381497ca5cefb83d778b7
+MISC ChangeLog 481 SHA256 1adc2bf2f842b8bb8c84bbd75156902e51699afe95c10e87c4af0d93efee3830 SHA512 07d5425f174ccf4c95f1e855927d6c7ccd6a66a14cd806070edb663e32557ff106d689233334362a0d25f9249fd73b795ea7e20a094e202046c76d9532b5294f WHIRLPOOL 4af7bc15ed566c9f124410841c59c709d210f3b56b9845c5a7f0013d6b4942a1a56007b023a22111dd597f14214927c7dc2c6d2f5e0486ff4f9d7d27387ffe5b
+MISC metadata.xml 760 SHA256 7b7a862bd1b87e5a2b019f2fe317af64635d824acc8a20b2e7181da7af725ff8 SHA512 53dc7185cfb216ccc3327a7253408205f66266455f473f2157cff39de91065f07e832df1c32892682940c12f7ac93cabc83da8f27d36066cdffc16076b0e991c WHIRLPOOL dff2b80470634991211fc570e41214244af44924d389b1c182ef590053422b407fdc04928a2ce9a48e44a606b3d1a055d1c8c12a724a1aae10e000a8fdfc72fb
diff --git a/dev-python/py-ubjson/metadata.xml b/dev-python/py-ubjson/metadata.xml
new file mode 100644
index 000000000000..cf642005f7ee
--- /dev/null
+++ b/dev-python/py-ubjson/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>vilnis.termanis@iotic-labs.com</email>
+ <name>Iotic Labs Ltd</name>
+ </maintainer>
+ <remote-id type="pypi">py-ubjson</remote-id>
+ <remote-id type="github">Iotic-Labs/py-ubjson</remote-id>
+ </upstream>
+ <longdescription>
+ This is a Python v3.2+ (and 2.7+) Universal Binary JSON encoder/decoder
+ based on the draft-12 specification
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/py-ubjson/py-ubjson-0.9.0.ebuild b/dev-python/py-ubjson/py-ubjson-0.9.0.ebuild
new file mode 100644
index 000000000000..57e0fd09c78e
--- /dev/null
+++ b/dev-python/py-ubjson/py-ubjson-0.9.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6})
+
+inherit distutils-r1
+
+DESCRIPTION="Universal Binary JSON encoder/decoder"
+HOMEPAGE="https://github.com/Iotic-Labs/py-ubjson https://pypi.python.org/pypi/py-ubjson"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"