summaryrefslogtreecommitdiff
path: root/dev-python/pyFFTW/pyFFTW-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-24 19:58:07 +0000
commit99abbc5e5a6ecd3fc981b45646fd8cb5d320377b (patch)
treeda76713365257a445f3ae3b95470917f59d46728 /dev-python/pyFFTW/pyFFTW-9999.ebuild
parent4935506e9a5cbfabd37c64093eac5f36c2ff0017 (diff)
gentoo resync : 24.02.2018
Diffstat (limited to 'dev-python/pyFFTW/pyFFTW-9999.ebuild')
-rw-r--r--dev-python/pyFFTW/pyFFTW-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyFFTW/pyFFTW-9999.ebuild b/dev-python/pyFFTW/pyFFTW-9999.ebuild
new file mode 100644
index 000000000000..e8c88d277ab0
--- /dev/null
+++ b/dev-python/pyFFTW/pyFFTW-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A pythonic python wrapper around FFTW"
+HOMEPAGE="https://github.com/pyFFTW/pyFFTW"
+
+LICENSE="BSD"
+SLOT="0"
+if [ "${PV}" = "9999" ]; then
+ KEYWORDS=""
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pyFFTW/pyFFTW.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/pyFFTW/pyFFTW/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+IUSE=""
+
+DEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ >=sci-libs/fftw-3.3:3.0="
+RDEPEND="${DEPEND}"