summaryrefslogtreecommitdiff
path: root/dev-python/pyacoustid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyacoustid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyacoustid')
-rw-r--r--dev-python/pyacoustid/Manifest5
-rw-r--r--dev-python/pyacoustid/metadata.xml20
-rw-r--r--dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild26
-rw-r--r--dev-python/pyacoustid/pyacoustid-1.1.5.ebuild32
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pyacoustid/Manifest b/dev-python/pyacoustid/Manifest
new file mode 100644
index 000000000000..25ca9ad972b4
--- /dev/null
+++ b/dev-python/pyacoustid/Manifest
@@ -0,0 +1,5 @@
+DIST pyacoustid-1.0.0.tar.gz 10476 BLAKE2B 363bf1bee4c124fc57126febf50c34a395ded074df8d3b9661b015b6b653f473ef79837f2078b7b21375d3b3624f75b1070d3c28ab3fa4d619e1ae088129898c SHA512 4eabf32e7d958bf7330e852184f5ddf3105007179ca2c45b75c1a5b0f0898649e703aa333cffccac85eb7b18b54255f2e5d588897adfb9f0ef2596e9c0b2fe5a
+DIST pyacoustid-1.1.5.tar.gz 11846 BLAKE2B 920894d914f5eac15bd62fab7a018937691e8eb7774fe65821bd6a8088e81dba19d178866bfd01b991750c6298714a1b51f948da987207a6adad1e0c1689afa4 SHA512 5b71446b9adbc73335b5962081e880365580b8e0aac746e8137e8819ba91d73ec41814eba13fd1b04c5bad5f2b5a3aaad57db118981ab4eac9dea12f709afe91
+EBUILD pyacoustid-1.0.0-r1.ebuild 651 BLAKE2B d49dfd64d56756094fdabe2866f4a16fd7c7d4668164c71b91974fd55ec9cddb243442f83d73d84a581bd7e7a8939aa1240b098e75bc6d1b55d119aacc2d74f2 SHA512 105d6c8f1274e15c43f381378ef73dd2aee258b5d5b44d64c0b1977fa08dfe7533b0a35f1a81d9b3e2ae3d9de5912a853ce4c7d513f80dc92cb7e31bcea69bf7
+EBUILD pyacoustid-1.1.5.ebuild 754 BLAKE2B be73fa3f3084aa6330d9c27a4ce7d2dc771c5c7b8b69044caf292df279c285ead7e0053cd3f9fdd6a2d057a81e4741771194ffff72b2b018e6565e9daaccc21d SHA512 9fe7c6a266d65d8443033319081b4d6574c03e85b0c66011ecbd29ce2f33695f6d6c0510aef64a779865ba08dc836779aa80f628fd65d8d877d93134e7bfe9d0
+MISC metadata.xml 911 BLAKE2B fc4c4a10000f8c9ebe95b4687cfa087b930b9f4ad3b2a94e8e6ef8e3d210ba618824cef6513ecedc4902172b3255b43096cd8e132b7e0a68498fc70b9b9bfb59 SHA512 fa81f319c0c6e6963e8b37570006e411374191551411005945dc64f0c75242a7585aab6830f13b527ab0efc7f2ce56e260571c372c93c8c026a775f49709cbee
diff --git a/dev-python/pyacoustid/metadata.xml b/dev-python/pyacoustid/metadata.xml
new file mode 100644
index 000000000000..2bc252775293
--- /dev/null
+++ b/dev-python/pyacoustid/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sir.suriv@gmail.com</email>
+ <name>Diogo Pereira</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Chromaprint and its associated Acoustid Web service make up a high-quality, open-source acoustic fingerprinting system. This package provides Python bindings for both the fingerprinting algorithm library, which is written in C but portable, and the Web service, which provides fingerprint lookups.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pyacoustid</remote-id>
+ <remote-id type="github">beetbox/pyacoustid</remote-id>
+ <bugs-to>https://github.com/beetbox/pyacoustid/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild b/dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..b2a85cadc4b2
--- /dev/null
+++ b/dev-python/pyacoustid/pyacoustid-1.0.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for Chromaprint acoustic fingerprinting and the Acoustid API"
+HOMEPAGE="https://pypi.org/project/pyacoustid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="media-libs/chromaprint
+ dev-python/audioread[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ use examples && local EXAMPLES=( ./aidmatch.py)
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyacoustid/pyacoustid-1.1.5.ebuild b/dev-python/pyacoustid/pyacoustid-1.1.5.ebuild
new file mode 100644
index 000000000000..413c07cfff86
--- /dev/null
+++ b/dev-python/pyacoustid/pyacoustid-1.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Chromaprint and the AcoustID web service"
+HOMEPAGE="https://pypi.org/project/pyacoustid/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/audioread[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ media-libs/chromaprint"
+
+src_install() {
+ distutils-r1_src_install
+
+ if use examples ; then
+ docinto examples
+ dodoc aidmatch.py fpcalc.py
+ docompress -x /usr/share/doc/${PF}/examples/
+ fi
+}