summaryrefslogtreecommitdiff
path: root/dev-python/pyaes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyaes
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyaes')
-rw-r--r--dev-python/pyaes/Manifest5
-rw-r--r--dev-python/pyaes/metadata.xml11
-rw-r--r--dev-python/pyaes/pyaes-1.6.0.ebuild23
-rw-r--r--dev-python/pyaes/pyaes-1.6.1.ebuild23
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pyaes/Manifest b/dev-python/pyaes/Manifest
new file mode 100644
index 000000000000..bcf57bcad603
--- /dev/null
+++ b/dev-python/pyaes/Manifest
@@ -0,0 +1,5 @@
+DIST pyaes-1.6.0.tar.gz 28237 SHA256 9cd5a54d914b1eebfb14fcb490315214b6a0304d9f1bb47e90d1d8e0b15ce92e SHA512 32f6bf998b7e200fc73b4852873f60067ac056d646ae87cd8ab55f3ec99c9e26fa2b418b67ba0264a8016311a5f0eb2d40c8e7f917c0715e19f5c3dbf6a8238e WHIRLPOOL 255679d20d40d7a9134465b39365bd6e077601e7882c2f17dd2d1e4198b88712782bfdb8d5d5dc7a74f5c8e5f124da0d396a3aa94dd2a858f53ec45fd8af7a61
+DIST pyaes-1.6.1.tar.gz 28536 SHA256 02c1b1405c38d3c370b085fb952dd8bea3fadcee6411ad99f312cc129c536d8f SHA512 00ce3babf72ea18b0de369860cd884058c7c6f3bd8b961c3ff591ef7d3dc0a69fabad5311f61c9f91d2f1a480c8512e34eeced5ec7145ed9f963bf91c5f8838a WHIRLPOOL 5dd013096329f669afc75bddf18c773d282f4b505185838cafab411ab4ba03b7dfa278e053f8c7101033bae0d3ad1c8d88548278917959116942909a2e095066
+EBUILD pyaes-1.6.0.ebuild 556 SHA256 7e9ab485b30782dde6d1bc57cb719c83ab446a66fb80cf5f35600b41fd79877f SHA512 c4a462428fbddccf281c512e290a0058a7ab40b4aaed6441b8626257a06762e6f5ca7dd9e4badf00ed4e93f88d6f5e6be0f4b426c2d2ee46d44b4f9aabca0145 WHIRLPOOL 2e901921ea9b77ac674980a63f49c40feaef615254792dfd3ecd808ac7718e22b9fce77883b61d3e67d0d124d6ef996eba2f66df59c5fd4053806299b18d8d8e
+EBUILD pyaes-1.6.1.ebuild 556 SHA256 7e9ab485b30782dde6d1bc57cb719c83ab446a66fb80cf5f35600b41fd79877f SHA512 c4a462428fbddccf281c512e290a0058a7ab40b4aaed6441b8626257a06762e6f5ca7dd9e4badf00ed4e93f88d6f5e6be0f4b426c2d2ee46d44b4f9aabca0145 WHIRLPOOL 2e901921ea9b77ac674980a63f49c40feaef615254792dfd3ecd808ac7718e22b9fce77883b61d3e67d0d124d6ef996eba2f66df59c5fd4053806299b18d8d8e
+MISC metadata.xml 330 SHA256 465197fa2d02768602232aef0aeacdfd17c8d06e1ba4c0169422c6d59d941dcc SHA512 709c6dd149b11725af862bb5d43be89be3f2432b0c3315e4d6cbbf45a98345b8bcbc092e9dd4d21b3501753f3fa9001d5d4ed5c6db6580ad311cc96c3c76cb9a WHIRLPOOL bf3c728ff96c46d9d220d3e188a2a89c10388c07dbf7d18de9a2d02a5b7520a9c2699ec0969b2b559472d8369bc1a6b2513982e5b928177ad66ae9902bbd12d0
diff --git a/dev-python/pyaes/metadata.xml b/dev-python/pyaes/metadata.xml
new file mode 100644
index 000000000000..936a7fedbd7d
--- /dev/null
+++ b/dev-python/pyaes/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>blueness@gentoo.org</email>
+ <name>Anthony G. Basile</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyaes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyaes/pyaes-1.6.0.ebuild b/dev-python/pyaes/pyaes-1.6.0.ebuild
new file mode 100644
index 000000000000..839a967746df
--- /dev/null
+++ b/dev-python/pyaes/pyaes-1.6.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python Implementation of the AES block-cipher and common modes of operation"
+HOMEPAGE="https://pypi.python.org/pypi/pyaes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} tests/test-{aes,blockfeeder,util}.py || die
+}
diff --git a/dev-python/pyaes/pyaes-1.6.1.ebuild b/dev-python/pyaes/pyaes-1.6.1.ebuild
new file mode 100644
index 000000000000..839a967746df
--- /dev/null
+++ b/dev-python/pyaes/pyaes-1.6.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python Implementation of the AES block-cipher and common modes of operation"
+HOMEPAGE="https://pypi.python.org/pypi/pyaes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} tests/test-{aes,blockfeeder,util}.py || die
+}