summaryrefslogtreecommitdiff
path: root/dev-python/pyarrow/pyarrow-16.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-14 00:09:04 +0100
commit5e41a38157bb40e8513e8e34426e85faba672fe7 (patch)
tree38e9365afd56c161d0e970ddf5420b2585130587 /dev-python/pyarrow/pyarrow-16.1.0.ebuild
parent0ebcd2cbf178600b5eb36b2f24cdbb3d2f4a9000 (diff)
gentoo auto-resync : 14:06:2024 - 00:09:04
Diffstat (limited to 'dev-python/pyarrow/pyarrow-16.1.0.ebuild')
-rw-r--r--dev-python/pyarrow/pyarrow-16.1.0.ebuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/dev-python/pyarrow/pyarrow-16.1.0.ebuild b/dev-python/pyarrow/pyarrow-16.1.0.ebuild
index 37167ff75b2c..7a027d3f6336 100644
--- a/dev-python/pyarrow/pyarrow-16.1.0.ebuild
+++ b/dev-python/pyarrow/pyarrow-16.1.0.ebuild
@@ -39,6 +39,11 @@ EPYTEST_XDIST=1
distutils_enable_tests pytest
src_prepare() {
+ local PATCHES=(
+ # https://github.com/apache/arrow/pull/42099
+ "${FILESDIR}/${P}-numpy-2.patch"
+ )
+
# cython's -Werror
sed -i -e '/--warning-errors/d' CMakeLists.txt || die
distutils-r1_src_prepare
@@ -83,14 +88,6 @@ python_test() {
tests/test_pandas.py::test_array_to_pandas_roundtrip
)
- if has_version ">=dev-python/numpy-2"; then
- EPYTEST_DESELECT+=(
- # https://github.com/apache/arrow/issues/41319
- tests/test_array.py::test_numpy_array_protocol
- tests/test_table.py::test_numpy_array_protocol
- )
- fi
-
cd "${T}" || die
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest --pyargs pyarrow