summaryrefslogtreecommitdiff
path: root/dev-python/pyarrow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-18 12:29:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-18 12:29:02 +0100
commitf85858c81a721c7fc89c1ab8df19e3a213dc27cd (patch)
tree3f0aeb33e434ee50b99bcc8b54158bc6169a41f2 /dev-python/pyarrow
parent16857b69f990738d17bc5842e3e49a6e82d1428d (diff)
gentoo auto-resync : 18:07:2024 - 12:29:01
Diffstat (limited to 'dev-python/pyarrow')
-rw-r--r--dev-python/pyarrow/Manifest2
-rw-r--r--dev-python/pyarrow/pyarrow-17.0.0.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/pyarrow/Manifest b/dev-python/pyarrow/Manifest
index fe04aabbbce5..27892eeb3af3 100644
--- a/dev-python/pyarrow/Manifest
+++ b/dev-python/pyarrow/Manifest
@@ -1,5 +1,7 @@
AUX pyarrow-16.1.0-numpy-2.patch 2950 BLAKE2B 89457b0b8c990b0fdc0409d72ef7326432a327dcd435277131e3bd2dd3506e3f3c8877edad37f318bac5627ff6c53c045115b5cfd91f887e21524b525aca4535 SHA512 5bd77755392f1cbfdc765a3bc713040cf75a9a4e824536a400f8c163633c41b1ebc38f4ba74be83e37c346789b34eb0a421bf549b4449ce31b613706effec859
AUX pyarrow-16.1.0-py313.patch 1860 BLAKE2B c7cf4cd0357280a51bbaf87ba5405699ebe0ab3433b5b0b7c4d917eb0103231887a33d4286e9c13e4159c90560e4d7112ccd071fce69b79441fe974f46c488f8 SHA512 c519ceafa47879fc49eef33457a3aa87e7274002ac23d01dbaeb4d0ad9a29a241c7bc3739f555c9df20f8489c377c6730fe9686983dd0ac3a2fe847fad16701f
DIST apache-arrow-16.1.0.tar.gz 21707079 BLAKE2B 5541c364351e59e8164f2461546bce3ddc834d70b3a03b815b681187674bdd89ccfb7eb113bf9010c821845b0c1fa51f5321bfea5b20927e6364f6452ec980d2 SHA512 28975f59e1fdde2dba4afaf4a5ba934b63db3a7f27656e2aa0af0f0d2a046c9dbfa9a6082de94629c36d03809b296566a37ea65ec5a2fc17fedac7d21e272d31
+DIST apache-arrow-17.0.0.tar.gz 21822331 BLAKE2B 64f9321cbf13fafae5938f26840d3ef642d6f5b40386315030bc70fe8703786ee394c8483d2bde7961cf2b5c15470ffebd7c66029e116b05cfbf5524e9fe51f1 SHA512 4e2a617b8deeb9f94ee085653a721904a75696f0827bcba82b535cc7f4f723066a09914c7fa83c593e51a8a4031e8bf99e563cac1ebb1d89604cb406975d4864
EBUILD pyarrow-16.1.0.ebuild 2629 BLAKE2B 7f6daf44bc3d5aa3257559ee56367a91d9437f78314febfc4bd5b00bd61f5d6255f1ff46efb15a56df4a945f6e56b79e512ed090afec5187a3d31db9faf55aed SHA512 14946af7cb7e1b39ac6be8dc4ea5fc70abe3f8e5f86a294567204928b0f81b0e352dcc288ca251ee70a79340370e2bb5bbc2f7dde41b041c4937885ddca04392
+EBUILD pyarrow-17.0.0.ebuild 2845 BLAKE2B e81c7c0b4a8140d6a0e6d6e50e06a87bcccd787961a75c4b6eb12a08119c5de9880773ca559cf32786813b9f4a80e7cbedf78aa4ceb77281e7b36c36a371a22f SHA512 00c1eeac708cac7681e577c0f4bc97d2f870e93060732d1601d2c3fe467a14f9d9b227f54f45e0f09abd4b6b39146fd9a07113282f3375421ece4c921f45fdc3
MISC metadata.xml 555 BLAKE2B 5683205ece2b0266e5792f42ebd515c1822563d2705f046ebcabd1de71efc67800616303b2fc83ea8cac3395303178f13e859b7390adfcef23da8d687fc8d6a3 SHA512 61d8f5bcbdbe92b858d0aab3040cd3e8dcb33ba0c45808649e032a165d6826c1a489ae2cfbf8dca52eda82d5b24b4c3f74a9abd6f87d5ff72f6578cf7535c797
diff --git a/dev-python/pyarrow/pyarrow-17.0.0.ebuild b/dev-python/pyarrow/pyarrow-17.0.0.ebuild
new file mode 100644
index 000000000000..1c2d5fde59a7
--- /dev/null
+++ b/dev-python/pyarrow/pyarrow-17.0.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Python library for Apache Arrow"
+HOMEPAGE="
+ https://arrow.apache.org/
+ https://github.com/apache/arrow/
+ https://pypi.org/project/pyarrow/
+"
+SRC_URI="mirror://apache/arrow/arrow-${PV}/apache-arrow-${PV}.tar.gz"
+S="${WORKDIR}/apache-arrow-${PV}/python"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="+parquet +snappy ssl"
+
+RDEPEND="
+ ~dev-libs/apache-arrow-${PV}[compute,dataset,json,parquet?,re2,snappy?,ssl?]
+ >=dev-python/numpy-1.16.6:=[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-libs/apache-arrow[lz4,zlib]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # cython's -Werror
+ sed -i -e '/--warning-errors/d' CMakeLists.txt || die
+}
+
+src_compile() {
+ export PYARROW_PARALLEL="$(makeopts_jobs)"
+ export PYARROW_BUILD_VERBOSE=1
+ export PYARROW_CXXFLAGS="${CXXFLAGS}"
+ export PYARROW_BUNDLE_ARROW_CPP_HEADERS=0
+ export PYARROW_CMAKE_GENERATOR=Ninja
+ export PYARROW_WITH_HDFS=1
+ if use parquet; then
+ export PYARROW_WITH_DATASET=1
+ export PYARROW_WITH_PARQUET=1
+ use ssl && export PYARROW_WITH_PARQUET_ENCRYPTION=1
+ fi
+ if use snappy; then
+ export PYARROW_WITH_SNAPPY=1
+ fi
+
+ distutils-r1_src_compile
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # wtf?
+ tests/test_fs.py::test_localfs_errors
+ # these require apache-arrow with jemalloc that doesn't seem
+ # to be supported by the Gentoo package
+ tests/test_memory.py::test_env_var
+ tests/test_memory.py::test_specific_memory_pools
+ tests/test_memory.py::test_supported_memory_backends
+ # hypothesis health check failures
+ # https://github.com/apache/arrow/issues/41318
+ tests/interchange/test_interchange_spec.py::test_dtypes
+ tests/test_convert_builtin.py::test_array_to_pylist_roundtrip
+ tests/test_feather.py::test_roundtrip
+ tests/test_pandas.py::test_array_to_pandas_roundtrip
+ tests/test_strategies.py::test_types
+ tests/test_types.py::test_hashing
+ # fragile memory tests
+ tests/test_csv.py::TestSerialStreamingCSVRead::test_batch_lifetime
+ tests/test_csv.py::TestThreadedStreamingCSVRead::test_batch_lifetime
+ # takes forever, and manages to generate timedeltas over 64 bits
+ tests/test_strategies.py
+ )
+
+ cd "${T}" || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs pyarrow
+}
+
+python_install() {
+ distutils-r1_python_install
+ # https://github.com/apache/arrow/issues/43299
+ rm -r "${D}$(python_get_sitedir)"/{benchmarks,cmake_modules,examples,scripts} || die
+}