summaryrefslogtreecommitdiff
path: root/dev-python/pyatspi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-07 00:55:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-07 00:55:44 +0000
commitf986d7fe50cd66c636620a90125850ff8d0f4a1c (patch)
tree51954bbef2363456f65ed2724742a0e781663249 /dev-python/pyatspi
parentcf7a256641d0729742707e68efe5e5ee3895b6c9 (diff)
gentoo auto-resync : 07:01:2024 - 00:55:44
Diffstat (limited to 'dev-python/pyatspi')
-rw-r--r--dev-python/pyatspi/Manifest2
-rw-r--r--dev-python/pyatspi/pyatspi-2.46.1.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pyatspi/Manifest b/dev-python/pyatspi/Manifest
index eb58a061ab5f..b54b7011056c 100644
--- a/dev-python/pyatspi/Manifest
+++ b/dev-python/pyatspi/Manifest
@@ -1,3 +1,5 @@
DIST pyatspi-2.46.0.tar.xz 324112 BLAKE2B 653e80be2d17f3246bb6bb60c2135f158185374c995ca37d4f132c90d0bf02b79cfcbc4f64d555c557e9f7fd1cf0720de2c5d177b303e35a84d8e4490ae2e660 SHA512 4e9d177c930db3ccb5aa41280e33a58b6700d9c45f08b6a2f32fce0ecf5f1faa3f91c57281a5661bb9ccaafd0935e90b44f328a62988ae838b4a008916d2aa0f
+DIST pyatspi-2.46.1.tar.xz 323392 BLAKE2B ee55f57616d58ead8bbf14193a984e2d268b0dafd67bdb638086fe531d7d031b6060f2c757036f67ad18ba6c1f774c8ef13a4844c5fb96878604f59903b2653a SHA512 69c1c4c31bef430083a1c9af98ba6b2f1b3d9eec0a5f03982b980838bcf86933069a90d7314d2e5501d5988a453d0a803ad239eca5b98f08cc3bf7dc8d4a7c0c
EBUILD pyatspi-2.46.0.ebuild 1327 BLAKE2B 6fd0b434a311ef99e3783cdeb11cc98c8b062242746daa05515d79b693c55229a50fe250b725a0f48a69b60659483c1be7d6877477f72c2520bcdbc671201140 SHA512 947cb62126e7107311cb547ff601bd20f640a97e26eb7ce289917e93fd761c75c60b3a41e2562e928202c020ddba6f6b4a307ec7e604277be135ee6cde8a6e96
+EBUILD pyatspi-2.46.1.ebuild 1331 BLAKE2B 99b45f7f61fb0d4bfb1d86c517d670c4fbeb6e0a8e416276426a64ff4344a06bb952e6a0f46acdaad622fd649479c9ba89be256620e3118f318e0a5cb9c06c72 SHA512 c64ef8257f445f4ce9044d87b912932147e241dbce48dae58a1f39474b823b90ff7d86847bb3c4bffe9b720295374fc2ac6ab582c398c2ee6f1abf6a60b900a2
MISC metadata.xml 349 BLAKE2B af48f6da9752ad965ab10c2bf3322d4321f084fc392c78e2c0fa1b48728f6b0f9e391b97ee9df9880fbba4c47ec798e0218f3800bb044ac8d9609066dc883580 SHA512 629ee6df4926ec37c3811388921ec024f7b1a50a819b74715dfac905b7830da3d7d64ae1886703b694049d06422d36e551d4296b2892cc43d60d45291d287840
diff --git a/dev-python/pyatspi/pyatspi-2.46.1.ebuild b/dev-python/pyatspi/pyatspi-2.46.1.ebuild
new file mode 100644
index 000000000000..c95ed5df7428
--- /dev/null
+++ b/dev-python/pyatspi/pyatspi-2.46.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Python client bindings for D-Bus AT-SPI"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+# Note: only some of the tests are GPL-licensed, everything else is LGPL
+LICENSE="LGPL-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/atk-2.11.2
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.90.1:3[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ >=sys-apps/dbus-1
+ >=app-accessibility/at-spi2-core-2.34[introspection]
+"
+BDEPEND="virtual/pkgconfig
+ test? ( x11-libs/gtk+:3 )
+"
+
+src_prepare() {
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure $(use_enable test tests)
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir dbus-run-session emake check
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installing
+
+ docinto examples
+ dodoc examples/*.py
+}