summaryrefslogtreecommitdiff
path: root/dev-python/pybluez
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pybluez
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pybluez')
-rw-r--r--dev-python/pybluez/Manifest5
-rw-r--r--dev-python/pybluez/metadata.xml15
-rw-r--r--dev-python/pybluez/pybluez-0.18-r1.ebuild30
-rw-r--r--dev-python/pybluez/pybluez-0.22.ebuild33
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pybluez/Manifest b/dev-python/pybluez/Manifest
new file mode 100644
index 000000000000..9095402942db
--- /dev/null
+++ b/dev-python/pybluez/Manifest
@@ -0,0 +1,5 @@
+DIST PyBluez-0.18.tar.gz 74501 BLAKE2B 59ff94cd001f98ef113b0c705c11171ce61e1cb69d2eb596161a3c52764dad64ec2e3f6c5b8c1eedf2bcc463de781e60bcea84413866d10e47e742851bb23f43 SHA512 ddd185ad90f7c6235e25182afccfb586efa0d361f38140f33718dc2d29ca62f3aa68867d075820afffd5ee2fbd306b907b565fbdfdf32f906657f6a3a8c779da
+DIST PyBluez-0.22.zip 109060 BLAKE2B 0bbe0d23b3baf0e76567f2dee8f38ca1460767179df15b52c545e84cd131d23a5ae3752dd7867aae6307fd98f0b2c5a5f55b23c550805e163675526696f559fb SHA512 c166a976d311eba73516aaf86ab42b100a39ebccd3d70f93ccb89f59c12127a857698dcfe4b25f8f689eee12187b5f35ccc8235e36cf012e73df155ba5adfae6
+EBUILD pybluez-0.18-r1.ebuild 582 BLAKE2B 7fb062aac76c37fd06584fa49ae0d2451b34ee9c8802165f056544f355c8e949c2d35a5b3d342c5940d1be0a2b5d8b95524bff72931b865a4a1b37db774aae4f SHA512 d582b4d4875a328bda3e76153fadcdb2b83aafb860d61d0504f4f7213676d8570c48675ab2e94dc803c4436eb52af265592a9ae095f7d469a679a38ef9ca050c
+EBUILD pybluez-0.22.ebuild 665 BLAKE2B 675d86b54c50129bafea00d8ffecef887f452c02e758c9b48ae7e289cdd2387fcac8bb97ca221c4999bb8e0c49fc701b1567ddd6508bfb1368082d431512c2ea SHA512 3cd1a673e281174ab3135f9421071d841241a417862ec68da22b1c5ff3ad8096e8fc63af13e1ee0d3cd0b9a532feb653956e7d23d6afff247a9fe79c71889627
+MISC metadata.xml 614 BLAKE2B 407faf55334b7e516c3d3a43000c2d886e6b02a23908878bf3b40b7ad62bbbfa8d9353f1751ab4b35cfdb5d1af2e695811dbaca58ba1e88722f9acce1cd57b9b SHA512 0a4c61d454bfe82c6491d87c2e807b52b0a223a695359ba6921852b43bc5afd37de44821fe6c65c06c5973d128ef158bb02ad13a1963d1909ae4bddfe64324af
diff --git a/dev-python/pybluez/metadata.xml b/dev-python/pybluez/metadata.xml
new file mode 100644
index 000000000000..0334f65093e0
--- /dev/null
+++ b/dev-python/pybluez/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>PyBluez is an effort to create Python wrappers around bluez to allow Python
+developers to use system bluetooth resources. It works on machines running the
+GNU/Linux operating system and the bluez bluetooth stack.</longdescription>
+ <upstream>
+ <remote-id type="github">karulis/pybluez</remote-id>
+ <remote-id type="pypi">PyBluez</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pybluez/pybluez-0.18-r1.ebuild b/dev-python/pybluez/pybluez-0.18-r1.ebuild
new file mode 100644
index 000000000000..4067c947963b
--- /dev/null
+++ b/dev-python/pybluez/pybluez-0.18-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_P="PyBluez-${PV}"
+
+DESCRIPTION="Python bindings for Bluez Bluetooth Stack"
+HOMEPAGE="https://github.com/karulis/pybluez"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="examples"
+
+DEPEND="net-wireless/bluez"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pybluez/pybluez-0.22.ebuild b/dev-python/pybluez/pybluez-0.22.ebuild
new file mode 100644
index 000000000000..12ea43bf7891
--- /dev/null
+++ b/dev-python/pybluez/pybluez-0.22.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+MY_P="PyBluez-${PV}"
+
+DESCRIPTION="Python bindings for Bluez Bluetooth Stack"
+HOMEPAGE="https://github.com/karulis/pybluez"
+SRC_URI="mirror://pypi/P/PyBluez/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+RDEPEND="net-wireless/bluez"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x usr/share/doc/${PF}/examples
+ fi
+}