summaryrefslogtreecommitdiff
path: root/dev-python/pycapnp/pycapnp-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-06 18:23:20 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-06 18:23:20 +0000
commitd37b97a25b8b10f748eead6574b01f893f140b01 (patch)
tree13e2a142a31cd193a39c63042a64cab29a1f7ae9 /dev-python/pycapnp/pycapnp-0.6.2.ebuild
parenta833e3f4a431b8eea751b7420e127787f9c92117 (diff)
gentoo resync : 06.12.2017
Diffstat (limited to 'dev-python/pycapnp/pycapnp-0.6.2.ebuild')
-rw-r--r--dev-python/pycapnp/pycapnp-0.6.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pycapnp/pycapnp-0.6.2.ebuild b/dev-python/pycapnp/pycapnp-0.6.2.ebuild
new file mode 100644
index 000000000000..8147a6362021
--- /dev/null
+++ b/dev-python/pycapnp/pycapnp-0.6.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapping of the Cap'n Proto library"
+HOMEPAGE="http://jparyani.github.io/pycapnp/ https://github.com/capnproto/pycapnp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE=""
+
+RDEPEND=">=dev-libs/capnproto-0.6:="
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ distutils-r1_src_prepare
+ # regen cython files
+ rm -f capnp/lib/capnp.cpp || die
+}