summaryrefslogtreecommitdiff
path: root/dev-python/pycares
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pycares
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pycares')
-rw-r--r--dev-python/pycares/Manifest2
-rw-r--r--dev-python/pycares/pycares-4.1.2.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index aa9609aa4ab7..b65edcd52d6a 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1,3 +1,5 @@
DIST pycares-4.0.0.tar.gz 43512 BLAKE2B cccfd5738582da570a2b9b17e6e31764ff2fffe4306f08c09374707a8e1c997ca7bdf0c867252c6ec66712622c927989c4d8bcad42075c48cb2af0a5364908e8 SHA512 796f14fb13c5e848b98459287d9658e8d81a48b2b6e08793f794bf9bcf7381bd400f43a07b50b23c4578579098dab5954beae09f8d35da7b809552f701d03b05
+DIST pycares-4.1.2.tar.gz 43668 BLAKE2B 4b26f8643ff5ce297981b0b60b3afb34b249138e8f702dd4aa0a38935e9e5338d048f3be1b4fb64d6d8b2259a279a8881dbd44b412c10427dbd7eee664e70495 SHA512 6fb2d24fb5f2638c55424608b02ebe9f630866d644decfb663ab9d8e2bb7a42629748fa220054747f9c36ce3dcb42f3b8e457c5c39009f94b564ff07efde0c84
EBUILD pycares-4.0.0.ebuild 726 BLAKE2B fb25f94b2d75866eae37be6e8d6b3634cb185a9fb96181dbfb6ab6f504e757d154c8aa5343c76f3042c2aecdec83b1d1a4540d0a54217314a703da001ec9edad SHA512 70cfe97a92e1c142754cb95d53cc017a02cfd8afc18440453790f970706e830149057bd230923b2a7aa5867918b617f15b8bbc6934651d8fa4be68a00bbdb87d
+EBUILD pycares-4.1.2.ebuild 831 BLAKE2B 1d2f9bef253be90d5e67fe352f2c358ee381f9f162e74923439379991536ed5419d489cdbe6a9cae569f400f61ff9d73a86723520d87d157d1341a8a9edb2418 SHA512 ffcf3c56bcbaf7bffce6b5ac3c611b552c14e1e51451d208e89b46741da25f6a6012db756bab511ca5dbb72794fca6f401f63c7174e6e41fac8dbd90bcc20bcd
MISC metadata.xml 444 BLAKE2B a68f545c6f704176b98ebb3665e2f56e4879016ea4ffa4f342954d568d6fe76ad67bcf9d521f694b8fc0f199bff50969eb646554fff4a78f8644ac44edda0cdf SHA512 fe893795f2031639d9fa27efcb8afbb5a3e0ac2eb2a05f0465391813d60fba07372633e40136ce38eb429bae95d1ae5dccecd0aba228537553524343133dd202
diff --git a/dev-python/pycares/pycares-4.1.2.ebuild b/dev-python/pycares/pycares-4.1.2.ebuild
new file mode 100644
index 000000000000..c24fe865ba50
--- /dev/null
+++ b/dev-python/pycares/pycares-4.1.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="https://github.com/saghul/pycares/"
+SRC_URI="https://github.com/saghul/pycares/archive/${P/_p/-fix}.tar.gz"
+S=${WORKDIR}/${PN}-${P/_p/-fix}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+DEPEND="net-dns/c-ares"
+BDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]
+ ${DEPEND}
+ ${BDEPEND}"
+BDEPEND+="
+ test? ( dev-python/idna[${PYTHON_USEDEP}] )"
+
+export PYCARES_USE_SYSTEM_LIB=1
+
+python_test() {
+ "${EPYTHON}" tests/tests.py -v || die
+}