summaryrefslogtreecommitdiff
path: root/dev-python/pycares
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 12:00:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 12:00:01 +0100
commita519cf56a0e5e456006d39c06f68de5e11c2f7e9 (patch)
treeeb3511664a62de4a02ec7f25a9a3935956e288ab /dev-python/pycares
parentd63d16d19ab9b58260753953a431d39230f2c362 (diff)
gentoo auto-resync : 07:10:2023 - 12:00:01
Diffstat (limited to 'dev-python/pycares')
-rw-r--r--dev-python/pycares/Manifest2
-rw-r--r--dev-python/pycares/pycares-4.4.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pycares/Manifest b/dev-python/pycares/Manifest
index 22b3814e7533..2769cfa72c1b 100644
--- a/dev-python/pycares/Manifest
+++ b/dev-python/pycares/Manifest
@@ -1,3 +1,5 @@
DIST pycares-4.3.0.gh.tar.gz 44577 BLAKE2B b69eeb34a2f8c9d7025dc74881431b3fc5489b7f7e9142bb9ecdaf217e495ad72b1a6a7dc484a52e6a01394bbfa6d0609b2054dd4a663176cfb73d980642a3e1 SHA512 1dad1a6722bdd2bc59cc4ca774cc9da243e61a442ef383c238714b1274e90359352c72d16a2c1af2fcce3ea92708a7e5cee89a9b3eb7c015f9a194051c685f52
+DIST pycares-4.4.0.tar.gz 821630 BLAKE2B c2bddc54db9cd6ba92d7c4fb3809609a8a3526bab68e4cf48f0fee2e7473828f70ca696be11b904e9c3f9241de8b13568cd0317c8cb305a4aca7356f1b74cfb5 SHA512 db387f21975d015e0fcb01972ffb018476d51331a7a49bb4c0bf23ccfa13dff3f8b9c21d5f11da8ece3018debf36b1cddea032ef860353203cf38ab2b3d01e8a
EBUILD pycares-4.3.0.ebuild 1128 BLAKE2B 64346cc7503a9b61722dfa64dd061a3376e5b9b52ebad0d7ef44053accc3be90a1c541a6580302b2cc4b5c69ea5e968a7bb4cf0cef9a045588d00893ea628af7 SHA512 1df0b4851e6592929fb7bcb36b1a091406eeb95c5f7df24804c51ed9be73193aaaded614ae35dcd464c257cea7dc31a3481c9c25118e4597899773cfddefe576
+EBUILD pycares-4.4.0.ebuild 1081 BLAKE2B 1f37303665ba2106e87758acda33ff2819fda75808ab596fec0161316274865e197de75a5a195220e7bca8c43229c62c31aa30d52c0a6b55d5239129ab423877 SHA512 6cc0c4cc32fdf9b618947f05a00710e274ba20d1f7e339491fd381b3293ebdc7b5dd73a9f03b030203c4237fa2a1735285c1382b98943f6cfb99c1b691ef1547
MISC metadata.xml 444 BLAKE2B a68f545c6f704176b98ebb3665e2f56e4879016ea4ffa4f342954d568d6fe76ad67bcf9d521f694b8fc0f199bff50969eb646554fff4a78f8644ac44edda0cdf SHA512 fe893795f2031639d9fa27efcb8afbb5a3e0ac2eb2a05f0465391813d60fba07372633e40136ce38eb429bae95d1ae5dccecd0aba228537553524343133dd202
diff --git a/dev-python/pycares/pycares-4.4.0.ebuild b/dev-python/pycares/pycares-4.4.0.ebuild
new file mode 100644
index 000000000000..64a4148b23ef
--- /dev/null
+++ b/dev-python/pycares/pycares-4.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python interface for c-ares"
+HOMEPAGE="
+ https://github.com/saghul/pycares/
+ https://pypi.org/project/pycares/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="test"
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+DEPEND="
+ net-dns/c-ares:=
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]
+ ${DEPEND}
+ ${BDEPEND}
+"
+BDEPEND+="
+ test? (
+ dev-python/idna[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # regression due to Internet changing (probably)
+ # https://github.com/saghul/pycares/issues/187
+ tests/test_all.py::DNSTest::test_query_class_chaos
+ # TODO
+ tests/test_all.py::DNSTest::test_custom_resolvconf
+)
+
+export PYCARES_USE_SYSTEM_LIB=1