summaryrefslogtreecommitdiff
path: root/dev-python/pychromecast/pychromecast-13.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 01:52:56 +0000
commitb46782805d0eed36ce9685f7e9abf25671f24d7d (patch)
tree4b7992f7355b710c35a7c4bfff9b57eb64e4c8b5 /dev-python/pychromecast/pychromecast-13.0.4.ebuild
parentd4d7098dcb2f9dd257109bbcb55fd40beda1b78d (diff)
gentoo auto-resync : 21:12:2022 - 01:52:55
Diffstat (limited to 'dev-python/pychromecast/pychromecast-13.0.4.ebuild')
-rw-r--r--dev-python/pychromecast/pychromecast-13.0.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pychromecast/pychromecast-13.0.4.ebuild b/dev-python/pychromecast/pychromecast-13.0.4.ebuild
new file mode 100644
index 000000000000..fde595d2503d
--- /dev/null
+++ b/dev-python/pychromecast/pychromecast-13.0.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python module to talk to Google Chromecast"
+HOMEPAGE="https://github.com/home-assistant-libs/pychromecast"
+S="${WORKDIR}/PyChromecast-${PV}"
+SRC_URI="mirror://pypi/P/PyChromecast/PyChromecast-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.19.1[${PYTHON_USEDEP}]
+ >=dev-python/python-zeroconf-0.25.1[${PYTHON_USEDEP}]"