summaryrefslogtreecommitdiff
path: root/dev-python/pychromecast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/pychromecast
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/pychromecast')
-rw-r--r--dev-python/pychromecast/Manifest3
-rw-r--r--dev-python/pychromecast/metadata.xml14
-rw-r--r--dev-python/pychromecast/pychromecast-4.1.0.ebuild25
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pychromecast/Manifest b/dev-python/pychromecast/Manifest
new file mode 100644
index 000000000000..9f5c3d6cdf1e
--- /dev/null
+++ b/dev-python/pychromecast/Manifest
@@ -0,0 +1,3 @@
+DIST PyChromecast-4.1.0.tar.gz 44463 BLAKE2B 3ee92cfe57134665621c347dda9b21a06fa1d000f840d25b49f843edef86e35e22b82c9d4f80b8e0ae6f5fabcc4662d7c619363686a37903e27d84e0f85c8fca SHA512 688014a115f3189fed5535e70622a7323e4a29fd65678aa14a302047c5246dbc6a932a8f4eabb58f9fcecc0f4bdbe627d1496a4b6d28e680ad4fac6dd902c825
+EBUILD pychromecast-4.1.0.ebuild 706 BLAKE2B 6d6869ec8953db731ff349600fc82cf4fad509c21dedb0092436f00d7da42d8c03ef935a529f0df2216b03c58e5b77eb03deb47b507262e41bd277f3dca86f32 SHA512 89e0e175391bc8567f0802a8951700f5de70317fedaa97e823fea53aa2165839fbca875be91123960851b8957145ca20dd20efc7f06a3267a47af74f83e95c2a
+MISC metadata.xml 455 BLAKE2B 1fc5a60702092a7f317262f9410b93a330e07f99221b42e58a9f1855eaa370350cffe1e1d2535e2ec116ee0b82687e9b6fb65d9af176314df726e4a8d3d78749 SHA512 d9ca042a81b58cfeafaa5e06b8d2be4f71ddec498ee6f7e6619ad24a6223ab68e3e99a43329344738b1fd6a61a6f771ce0d58b2643e739d836565f977c9d7eb2
diff --git a/dev-python/pychromecast/metadata.xml b/dev-python/pychromecast/metadata.xml
new file mode 100644
index 000000000000..24fcd1714e2b
--- /dev/null
+++ b/dev-python/pychromecast/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Library for Python 2 and 3 to communicate with the Google Chromecast.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pychromecast/pychromecast-4.1.0.ebuild b/dev-python/pychromecast/pychromecast-4.1.0.ebuild
new file mode 100644
index 000000000000..382fbb243999
--- /dev/null
+++ b/dev-python/pychromecast/pychromecast-4.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Python module to talk to Google Chromecast."
+HOMEPAGE="https://github.com/balloob/pychromecast"
+SRC_URI="mirror://pypi/P/PyChromecast/PyChromecast-${PV}.tar.gz"
+S="${WORKDIR}/PyChromecast-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/zeroconf-0.17.7[${PYTHON_USEDEP}]
+ >=dev-python/casttube-0.2.0[${PYTHON_USEDEP}]"
+BDEPEND=""