summaryrefslogtreecommitdiff
path: root/dev-python/pycipher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pycipher
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pycipher')
-rw-r--r--dev-python/pycipher/Manifest3
-rw-r--r--dev-python/pycipher/metadata.xml11
-rw-r--r--dev-python/pycipher/pycipher-0.2-r1.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pycipher/Manifest b/dev-python/pycipher/Manifest
new file mode 100644
index 000000000000..1c6b1be404ac
--- /dev/null
+++ b/dev-python/pycipher/Manifest
@@ -0,0 +1,3 @@
+DIST pycipher-0.2.py 9174 BLAKE2B aeb994f58452bb8e8808f48a217ceace8118e9fa378d9af9eaa68fd4a28aac0b7b0a23e9e66c28b4359f0e723a062007a82d5fa949f0ccd86f2c0b2a707195ac SHA512 ce3890184affc761fcac7a19284437ca5bd7fd5be6594dc6112eccc27971ca2a62cdff106bffea29c94f3dbc8bbee5f67af3bcd3a53838a1c7bfb19dad45dcda
+EBUILD pycipher-0.2-r1.ebuild 649 BLAKE2B 9031c3325b2540aa70496adb2a24d81a14a150d02226e043c85feef380f97c2be518fb2fcd0ee240e2fba0c2dcdc02db26a6bf6b9329f80a52b5b3472c16d048 SHA512 dca1ae37fd545ccf9b5c467b261c21fff9e52b2bf99a12eef6f12f4c330a2e1de023d48523e110dc79584650d4f4e4ee1793b0a7855e4cea51e132dd74754c1b
+MISC metadata.xml 318 BLAKE2B c4e881cdabe022937899237f2e89fd584a1f667c9b051844449cf809a35c18854e083006482defa161a929c98b94305fc3af869e2f744cadee5286ae594d2895 SHA512 5038596f685157e786f10f04e89d766479e8f29262787969d36f2aae2d5ad8031e0233b3a2d1176e4d007cd5c01534d82863ea19ad85715dfb3b0cd979f53a01
diff --git a/dev-python/pycipher/metadata.xml b/dev-python/pycipher/metadata.xml
new file mode 100644
index 000000000000..f47702af04df
--- /dev/null
+++ b/dev-python/pycipher/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pycipher</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycipher/pycipher-0.2-r1.ebuild b/dev-python/pycipher/pycipher-0.2-r1.ebuild
new file mode 100644
index 000000000000..81e3ead1bbdf
--- /dev/null
+++ b/dev-python/pycipher/pycipher-0.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit python-r1
+
+DESCRIPTION="A Python module that implements several well-known classical cipher algorithms"
+HOMEPAGE="http://pycipher.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.py"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ mkdir "${S}" || die
+ cp "${DISTDIR}/${A}" "${S}/${PN}.py" || die
+}
+
+src_install() {
+ python_foreach_impl python_domodule ${PN}.py
+}