summaryrefslogtreecommitdiff
path: root/dev-python/pycollada
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pycollada
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pycollada')
-rw-r--r--dev-python/pycollada/Manifest3
-rw-r--r--dev-python/pycollada/metadata.xml11
-rw-r--r--dev-python/pycollada/pycollada-0.4.ebuild64
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pycollada/Manifest b/dev-python/pycollada/Manifest
new file mode 100644
index 000000000000..b2ad4c7b4187
--- /dev/null
+++ b/dev-python/pycollada/Manifest
@@ -0,0 +1,3 @@
+DIST pycollada-0.4.tar.gz 519732 BLAKE2B 9fd9b7ca369943cb6b2d9960b343ed39a9e578bb2e94c06d5e7c027a814220b13ff66d6137371edab150befd4b4301e9cf5420385f7dd3ad72dc11a38c38afa9 SHA512 6e9569b858f2014aa08764d0bf328c8317b94edc91e99c2a7c97bf2355983555ea103012d6e6f197862cb3df113ca9263de18fc47edb3c60e74fa8e58b5ca8b0
+EBUILD pycollada-0.4.ebuild 1263 BLAKE2B 5ec572af9cf78ad57a863e26f0f5e60cfb84db0404b284efc45ba85c03fae3f896840a82bcd3a8e3e25c1e2e939c93847b33c9675f08a14e9876e1c4ddab29d1 SHA512 f220da283c4bfca03b0c22c14f9a7a9693e8f50dd271392252f435cbf4e8eb3a813d7928807e57a3c572912cda156c7e27b18d4e1e5f7c335b9a392baddf1834
+MISC metadata.xml 327 BLAKE2B f1ea87e797a3f8379e6f5cc0b84b7fff48f28b56b71ba4b17fa1a12cc8148dd2a09176ae5fb1f727f1cb0a260cb395f184c2a1bb4109f5450e8bc77124531f12 SHA512 a413c6d76aa3a80cf2f32c4cc75760c0574019eff6d381c1f46aefe4bc7924e59f28d593691b2ac7bb0a7afa7fcdb11a264f3bbc600bfab61148634282307886
diff --git a/dev-python/pycollada/metadata.xml b/dev-python/pycollada/metadata.xml
new file mode 100644
index 000000000000..9438ce631d39
--- /dev/null
+++ b/dev-python/pycollada/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pycollada/pycollada</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycollada/pycollada-0.4.ebuild b/dev-python/pycollada/pycollada-0.4.ebuild
new file mode 100644
index 000000000000..91e85d338acd
--- /dev/null
+++ b/dev-python/pycollada/pycollada-0.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_MULTIPLE_ABI=1
+
+inherit distutils-r1
+
+DESCRIPTION="python library for reading and writing collada documents"
+HOMEPAGE="https://pycollada.github.com/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/python-dateutil )"
+RDEPEND="dev-python/numpy
+ dev-python/lxml
+ >=dev-python/python-dateutil-2.0"
+
+src_compile() {
+ distutils-r1_src_compile
+
+ if use doc ; then
+ pushd docs
+ emake html
+ popd
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ if use doc ; then
+ pushd docs/_build/html
+ dohtml -r *
+ popd
+ fi
+
+ if use examples ; then
+ insinto /usr/share/${P}/
+ doins -r examples
+ fi
+
+ install_test_data() {
+ insinto $(python_get_sitedir)/collada/tests/
+ doins -r collada/tests/data
+ }
+ python_foreach_impl install_test_data
+}
+
+src_test() {
+ test_collada() {
+ for script in "${S}"/collada/tests/*.py ; do
+ PYTHONPATH="${S}" $EPYTHON "${script}"
+ done
+ }
+ python_foreach_impl test_collada
+}