summaryrefslogtreecommitdiff
path: root/dev-python/pycountry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pycountry
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pycountry')
-rw-r--r--dev-python/pycountry/Manifest5
-rw-r--r--dev-python/pycountry/metadata.xml14
-rw-r--r--dev-python/pycountry/pycountry-16.11.8.ebuild30
-rw-r--r--dev-python/pycountry/pycountry-17.9.23.ebuild30
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/pycountry/Manifest b/dev-python/pycountry/Manifest
new file mode 100644
index 000000000000..e304a2e4296c
--- /dev/null
+++ b/dev-python/pycountry/Manifest
@@ -0,0 +1,5 @@
+DIST pycountry-16.11.8.tar.gz 9042735 BLAKE2B 66f5dcb0b9b55be692e398c998babeb49542cb5383a706bb74091088eaa3703f41da33f59e2267046c53f8f025f85945096d1e8d251ad5af57c5d39a27896cf2 SHA512 eb0a91f1efae6aeace0b49cd44b0770efa0b57add208c4247e7f58a3c46774f9f8007c51ee88a0e108c90ced3ad69204b4322c9c23f51df0b2202aa98c314a37
+DIST pycountry-17.9.23.tar.gz 9208478 BLAKE2B 381497b220991f76bdac235b71fd9c10984f5762e9cc16b813cb37cfef0444bbaada01e1ed9513848c681a06335ff58544f6f7c2217b51ef98c7415db4b3d285 SHA512 168e2d2693629a39a85a4c6aa7187323693ca73d6af0cc947d3536ae373eca602e7e3add91ba114966db4ebf52118ef3d6a3dbf8339734ec68682bab559beeb5
+EBUILD pycountry-16.11.8.ebuild 899 BLAKE2B 2dda12a1702376213f066862721dff6ae0a3daf3648a59d85563dc20f0379b15e0e94fa6b30e497fecbc8b41ab0a7afa0f3eab2a339e4ce07fab4c4b1a76b940 SHA512 09210a258600481ad258786cfd9762b9abd10a3a0aabab6951232373f566b775297bb376f287f39f34e249ea58b98c14bac5406785976ef151b91787f18e9c18
+EBUILD pycountry-17.9.23.ebuild 902 BLAKE2B be0b84f41859a6c5a83818cec37eef308d6b8b5adf6884d471db28eb1e58367ba62e94a034adc981248fc8408db31b7556fde4e21c012f1b4fe6464ea6f7ee1b SHA512 99147ddc6406ceafc009e0f7e86fb244d19a2b746e0c63c3ed95bdf60bf3eec0731a596b90dd61de021bac530a6af70b95732a7782640f157aceeb538e1d5bfc
+MISC metadata.xml 516 BLAKE2B 8e3dabec1ed6b181d44db184d87d2a7b05bef670aae39e71bc35c8d3fbd8e606c929b4b7abe5b8d6d8faa69ca373238fbb8c31d40334ef87d8ff6f07ea1c6f53 SHA512 901c2f02b6dcaacbaae30e82fe886b104051a434ed4c079443a77f5b474cef24f16f658cbe7c01a30966126af78d7950f65207bb8b16e2e1c9bfc71bc05d0c3a
diff --git a/dev-python/pycountry/metadata.xml b/dev-python/pycountry/metadata.xml
new file mode 100644
index 000000000000..d3c69a8b0ffa
--- /dev/null
+++ b/dev-python/pycountry/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">ISO country, subdivision, language, currency and script definitions and
+ their translations</longdescription>
+ <upstream>
+ <remote-id type="pypi">pycountry</remote-id>
+ <remote-id type="bitbucket">flyingcircus/pycountry</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycountry/pycountry-16.11.8.ebuild b/dev-python/pycountry/pycountry-16.11.8.ebuild
new file mode 100644
index 000000000000..1cb7ab86604d
--- /dev/null
+++ b/dev-python/pycountry/pycountry-16.11.8.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://bitbucket.org/flyingcircus/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc ~sparc x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ if [[ "${EPYTHON}" == pypy || "${EPYTHON}" == pypy3 ]]; then
+ sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+ fi
+ py.test ${PN}/tests/test_general.py || die
+ popd > /dev/null
+}
diff --git a/dev-python/pycountry/pycountry-17.9.23.ebuild b/dev-python/pycountry/pycountry-17.9.23.ebuild
new file mode 100644
index 000000000000..5ab90f36de86
--- /dev/null
+++ b/dev-python/pycountry/pycountry-17.9.23.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Database of countries, subdivisions, languages, currencies and script"
+HOMEPAGE="https://bitbucket.org/flyingcircus/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ # https://bitbucket.org/techtonik/pycountry/issue/8/test_locales-pycountry-015-pypy
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ if [[ "${EPYTHON}" == pypy || "${EPYTHON}" == pypy3 ]]; then
+ sed -e 's:test_locales:_&:' -i pycountry/tests/test_general.py || die
+ fi
+ py.test ${PN}/tests/test_general.py || die
+ popd > /dev/null
+}