summaryrefslogtreecommitdiff
path: root/dev-python/pycparser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/pycparser
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/pycparser')
-rw-r--r--dev-python/pycparser/Manifest2
-rw-r--r--dev-python/pycparser/pycparser-2.21.ebuild76
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pycparser/Manifest b/dev-python/pycparser/Manifest
index 00ffb996fbbf..c24d87dc0b55 100644
--- a/dev-python/pycparser/Manifest
+++ b/dev-python/pycparser/Manifest
@@ -1,3 +1,5 @@
DIST pycparser-2.20.tar.gz 161330 BLAKE2B 9a114e4b73e6c3c495bd78c393957146ec425eb5b15d72266cbf424f15e8d2e2e6402ef36d60a9dff41b393aab80fe1356befd25549517f398e129836a76b037 SHA512 ff0853c9f981b43b4f2e879350715c07b02cf9dab223d4980d8fe0a3138c98041b5f848a9355ae4f1cb45e7f137c03a88843008e18d77af9250e0d9c55f5ca1b
+DIST pycparser-2.21.tar.gz 170877 BLAKE2B ae6bf42dfc552bf1e3bfb5430cdb0c15b5e011ec53cbd03e0e2507c08a1a78690cefce2de134bd984caccc5dbde90661cb4c18df5c289217967213aac4d52404 SHA512 e61fbdde484d1cf74d4b27bdde40cf2da4b7028ca8ecd37c83d77473dab707d457321aecaf97da3b114c1d58a4eb200290b76f9c958044b57e5fed949895b5f0
EBUILD pycparser-2.20-r1.ebuild 1721 BLAKE2B c58d45c46b908a76f5fda2efdbd74d3d94af70c67a51721f1fd27bb3d021783aa0fd1a4585b847da7f49a3b4ad002347f9179de57fb0fea88e5ad6a83c97c611 SHA512 09ac290d1f5f9bbd4e95545194a81594321a759f3f2e055b1991ead847dd095ae863a2b449f2f7dd5f4db70d48464442eb82e57231d4b46d7cfb16af93c0a278
+EBUILD pycparser-2.21.ebuild 2236 BLAKE2B f9bc2eb35c4fdb7b518714bfd51a3ab84ddca706097da74c21ca36b4a20b68411feab7739f6c7d2f0ab424a8a4b00d4d11e944f59fad028aea6580b883a7d46c SHA512 c857f6197a7f524486573ce1abc350c0c20c8f136851682337878d7c84cba94a6c2fdcf4ac4d1ade5e1d5acafe6dd531651a394ebc0e892aaa53c6d59cff6884
MISC metadata.xml 381 BLAKE2B ceed0b1da227f2b8016d51e7a6d6b9980d29c1dd930c9c5843c66ab62e3366f48f943bfd06155e9884fe08ab13da1844f7193a142d9d3f8f1db1a0ea5a9d3474 SHA512 e2603fae46f989057b80f13828825388f54f179b6dd9beeaad64e0eaa97ebd753e5eac752d79df460c31e9cfeb795998887964bdf92b364f5b7d7b6b2d65a21f
diff --git a/dev-python/pycparser/pycparser-2.21.ebuild b/dev-python/pycparser/pycparser-2.21.ebuild
new file mode 100644
index 000000000000..449a6b1bde3c
--- /dev/null
+++ b/dev-python/pycparser/pycparser-2.21.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="C parser and AST generator written in Python"
+HOMEPAGE="https://github.com/eliben/pycparser"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # remove the original files to guarantee their regen
+ rm pycparser/{c_ast,lextab,yacctab}.py || die
+
+ # kill sys.path manipulations to force the tests to use built files
+ sed -i -e '/sys\.path/d' tests/*.py || die
+
+ # Ensure we can find tests in our directory
+ sed -i -e 's/from tests.test_util/from test_util/g' tests/test_*.py || die
+
+ ln -s "${S}"/examples tests/examples || die
+
+ rm tests/test_examples.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # note: tables built by py3.5+ are incompatible with older versions
+ # because of 100 group limit of 're' module -- just generate them
+ # separately optimized for each target instead
+ pushd "${BUILD_DIR}"/lib/pycparser > /dev/null || die
+ "${PYTHON}" _build_tables.py || die
+ popd > /dev/null || die
+}
+
+python_test() {
+ # Skip tests if cpp is not in PATH
+ type -P cpp >/dev/null || return 0
+ # change workdir to avoid '.' import
+ cd tests || die
+
+ # Ensure that 'cpp' is called with the right arguments
+ # Tests don't seem to always pass the include they intend to use.
+ mkdir -p "${T}"/bin || die
+ cat > "${T}"/bin/cpp <<-EOF || die
+ #!${BROOT}/bin/bash
+ exec ${BROOT}/usr/bin/cpp -I${S}/utils/fake_libc_include/ \$@
+ EOF
+ chmod +x "${T}"/bin/cpp || die
+
+ PATH="${T}/bin:${PATH}" eunittest
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # setup.py generates {c_ast,lextab,yacctab}.py with bytecode disabled.
+ python_optimize
+}