summaryrefslogtreecommitdiff
path: root/dev-python/pycpio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-16 12:27:58 +0100
commitb6fa31c964a602f8461a77d5b83355e8750c12eb (patch)
tree323fa7af31640b3ea8bb57fa7a927713f3d64769 /dev-python/pycpio
parent868fd5dc8aab84930cfaa5252b8be06b35552765 (diff)
gentoo auto-resync : 16:07:2024 - 12:27:58
Diffstat (limited to 'dev-python/pycpio')
-rw-r--r--dev-python/pycpio/Manifest4
-rw-r--r--dev-python/pycpio/metadata.xml15
-rw-r--r--dev-python/pycpio/pycpio-1.2.1.ebuild18
-rw-r--r--dev-python/pycpio/pycpio-9999.ebuild17
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pycpio/Manifest b/dev-python/pycpio/Manifest
new file mode 100644
index 000000000000..deb7e0f9bf98
--- /dev/null
+++ b/dev-python/pycpio/Manifest
@@ -0,0 +1,4 @@
+DIST pycpio-1.2.1.tar.gz 18512 BLAKE2B e835e3810d174d8f4cd5afc2984c0d84d55f9492725c16afdcd1b760dc8c58b4b83a1d13c0b266c8ec9407ab5c1114fe95468d742b202ba99e3c4a76a69dff15 SHA512 4611829339a45a848deb0c5c35098215ac7c378714e4fb1e10975e00b386e5e6bcd295fde83f361998f234f506276b906a4424a7d4aa925fe2bd92a0d7311d86
+EBUILD pycpio-1.2.1.ebuild 480 BLAKE2B 896f72a8ef9df5e0ebbdc9f8d16c9da8f5bf836ea3079b04f7bc38ba5a8dc36d9ec923a2b845db8ddb048ca471618b8aa1e5ec563e1fa9f428a83a6df7b8e84c SHA512 90fb452fce57ffefe1e9089d56e604908eef62fc24dba00e823059a49d68b67f0d03f68f2ad417d4c789393e3cd0566bac5e20f07f1ed2f6dc6346416e9368c5
+EBUILD pycpio-9999.ebuild 422 BLAKE2B abd9980108ce47bb504aa825a15636ea3bdf271f90e6e22962329e600c137cdba1a32ae18e62636ab08dfe5fc7bdfb3aaf2718d481b4e15317efd293ae382db7 SHA512 606fced076d1b5746de9229c35c4d8e876b67f91ec377b884b617615afddf47b3608fb6bb5f1145a5c2ea25c83716174e9ad609ec27478c4c021cd6de74e8253
+MISC metadata.xml 461 BLAKE2B 9a8cbd11b569f3357ec70357d03545274f1f3532ad47ad1284fd6f657d0680bdef37a2e73efaa4781f8f22266caa271cfc74fe92797ade23e872352d930fe6e1 SHA512 7e534ff6f145a90c54317ad00165aaeecd00a807481ad5fba92b410f39fa5c9cd0c8f3d451d37ab9ad5861c383c6e051e487b6e3ef9a3c63531462c975d1713b
diff --git a/dev-python/pycpio/metadata.xml b/dev-python/pycpio/metadata.xml
new file mode 100644
index 000000000000..437ae2e18ded
--- /dev/null
+++ b/dev-python/pycpio/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>dev@pyl.onl</email>
+ <name>Zen</name>
+ </maintainer>
+ <maintainer type="person" proxied="proxy">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">desultory/PyCPIO</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pycpio/pycpio-1.2.1.ebuild b/dev-python/pycpio/pycpio-1.2.1.ebuild
new file mode 100644
index 000000000000..48966fa068b0
--- /dev/null
+++ b/dev-python/pycpio/pycpio-1.2.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1
+
+DESCRIPTION="Python CPIO library"
+HOMEPAGE="https://github.com/desultory/pycpio"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND=">=dev-python/zenlib-2.1.2[${PYTHON_USEDEP}]"
diff --git a/dev-python/pycpio/pycpio-9999.ebuild b/dev-python/pycpio/pycpio-9999.ebuild
new file mode 100644
index 000000000000..190f9a014b59
--- /dev/null
+++ b/dev-python/pycpio/pycpio-9999.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Python CPIO library"
+HOMEPAGE="https://github.com/desultory/pycpio"
+EGIT_REPO_URI="https://github.com/desultory/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=dev-python/zenlib-2.1.2[${PYTHON_USEDEP}]"