summaryrefslogtreecommitdiff
path: root/dev-python/pycrdt-websocket/pycrdt-websocket-0.12.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-24 19:00:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-24 19:00:40 +0000
commita7689c2abcff4374b84d95fb2df980ec9a566965 (patch)
treec3a326274492772c07c074a813f1047d5d7f3d62 /dev-python/pycrdt-websocket/pycrdt-websocket-0.12.7.ebuild
parentb1193c219a8c8da6e1e76cb5d394da129abbca41 (diff)
gentoo auto-resync : 24:03:2024 - 19:00:40
Diffstat (limited to 'dev-python/pycrdt-websocket/pycrdt-websocket-0.12.7.ebuild')
-rw-r--r--dev-python/pycrdt-websocket/pycrdt-websocket-0.12.7.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pycrdt-websocket/pycrdt-websocket-0.12.7.ebuild b/dev-python/pycrdt-websocket/pycrdt-websocket-0.12.7.ebuild
new file mode 100644
index 000000000000..186b6e0703b6
--- /dev/null
+++ b/dev-python/pycrdt-websocket/pycrdt-websocket-0.12.7.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="WebSocket connector for pycrdt"
+HOMEPAGE="https://github.com/jupyter-server/pycrdt-websocket"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/pycrdt-0.8.7[${PYTHON_USEDEP}]
+ dev-python/aiosqlite[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+)"
+
+# skip tests that depends on yjs not available in Gentoo
+EPYTEST_DESELECT=(
+ tests/test_pycrdt_yjs.py::test_pycrdt_yjs
+)
+
+distutils_enable_tests pytest