summaryrefslogtreecommitdiff
path: root/dev-python/pycrypto/pycrypto-2.6.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pycrypto/pycrypto-2.6.1-r2.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pycrypto/pycrypto-2.6.1-r2.ebuild')
-rw-r--r--dev-python/pycrypto/pycrypto-2.6.1-r2.ebuild75
1 files changed, 0 insertions, 75 deletions
diff --git a/dev-python/pycrypto/pycrypto-2.6.1-r2.ebuild b/dev-python/pycrypto/pycrypto-2.6.1-r2.ebuild
deleted file mode 100644
index 33ff67ea4eba..000000000000
--- a/dev-python/pycrypto/pycrypto-2.6.1-r2.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python Cryptography Toolkit"
-HOMEPAGE="https://www.dlitz.net/software/pycrypto/
- https://pypi.org/project/pycrypto/"
-SRC_URI="http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/${P}.tar.gz"
-
-LICENSE="PSF-2 public-domain"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~x86-solaris"
-IUSE="doc +gmp test"
-
-RDEPEND="gmp? ( dev-libs/gmp:0= )"
-DEPEND="${RDEPEND}
- doc? (
- dev-python/docutils[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/epydoc-3[${PYTHON_USEDEP}]' 'python2*')
- )"
-
-REQUIRED_USE="test? ( gmp )"
-
-DOCS=( ACKS ChangeLog README TODO )
-PATCHES=(
- "${FILESDIR}"/${P}-cross-compile.patch
- "${FILESDIR}"/${P}-CVE-2013-7459.patch
-)
-
-python_prepare_all() {
- # Fix Crypto.PublicKey.RSA._RSAobj.exportKey(format="OpenSSH") with Python 3
- # https://github.com/dlitz/pycrypto/commit/ab25c6fe95ee92fac3187dcd90e0560ccacb084a
- sed \
- -e "/keyparts =/s/'ssh-rsa'/b('ssh-rsa')/" \
- -e "s/keystring = ''.join/keystring = b('').join/" \
- -e "s/return 'ssh-rsa '/return b('ssh-rsa ')/" \
- -i lib/Crypto/PublicKey/RSA.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- # the configure does not interact with python in any way,
- # it just sets up the C header file.
- econf \
- $(use_with gmp) \
- --without-mpir
-}
-
-python_compile_all() {
- if use doc; then
- rst2html.py Doc/pycrypt.rst > Doc/index.html || die
- epydoc --config=Doc/epydoc-config --exclude-introspect="^Crypto\.(Random\.OSRNG\.nt|Util\.winrandom)$" || die
- HTML_DOCS=( Doc/apidoc/. Doc/index.html )
- fi
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS}"
- append-cflags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}