summaryrefslogtreecommitdiff
path: root/dev-python/pycuda
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-26 17:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-26 17:40:44 +0000
commitfab95e98818bada1626a7723a1348f4e920d25e0 (patch)
tree8f2d17919a6a012a482e3ad069d44e54739c6249 /dev-python/pycuda
parent533b7fe309e51c571ca6fe8fdd4453537d4f662a (diff)
gentoo auto-resync : 26:02:2024 - 17:40:44
Diffstat (limited to 'dev-python/pycuda')
-rw-r--r--dev-python/pycuda/Manifest2
-rw-r--r--dev-python/pycuda/pycuda-2022.2.2.ebuild93
2 files changed, 0 insertions, 95 deletions
diff --git a/dev-python/pycuda/Manifest b/dev-python/pycuda/Manifest
index aa9a6e64f1b9..b83453cfe2b3 100644
--- a/dev-python/pycuda/Manifest
+++ b/dev-python/pycuda/Manifest
@@ -1,5 +1,3 @@
-DIST pycuda-2022.2.2.tar.gz 1682953 BLAKE2B d60e83ac2faa183e0fa022c3d901c9d97ec2f9a59195425b9d71467c24b154d48d5735223220b41aa58b0898800d382d9ead54166d0a59db9c2a777e03e574be SHA512 c62aafe473e44339ac2147d86b51fc9bc2429310450b6d99e78a127828cc3a42dc74f20e1bdf8261f6652aed6d07ee3a871ce371f89f33fbcc4014f551af0b96
DIST pycuda-2024.1.tar.gz 1683163 BLAKE2B b464f47d86b77d492322f28364756cd25a28a11e6dcc802c9c930fad20de74d217660782f82a2a020753fcbb6000a9d659555be6220c57229226ac7fc118c793 SHA512 70a3f27488077e1176aa26b4bc8785277917cc1884126de45c732f393e5e38224b4c4c67999eb1776c08a930333f718d1af3463154d89291b3294bf303a3c471
-EBUILD pycuda-2022.2.2.ebuild 2343 BLAKE2B cf2526ee176a7b30cd349e68bb310781a37b01c03b5bc23cc45be313eb4c59e14293811c9c4f784975c89b7db4b2c16851dbcd68af174ad1c14c6c8f4bd8f804 SHA512 28900ad6f60c6403a67f7226d09173fb9103d3b8bfb6124e23b28dfeb302e5cc885dc121b6a7230a78c0593e5960edd1ae815be4a7442bf789efaa1bce8e3698
EBUILD pycuda-2024.1.ebuild 2250 BLAKE2B f6d5b61e6f87a45846ad0f8f999f8aeebdb762956f37d8d2fce516e1964d1d7c3f6c838f54ea9cf401ad3dee850eee9cda10fc93b8da7ff8997d677f4214ce19 SHA512 59659c09e77d51a27be39c0b4d07d0137156e8dafcc054086137ae665f060aeeb30815f31214c67fefa1825120cf1f9b6462370c7b01a19b932e8c9d65da9a47
MISC metadata.xml 389 BLAKE2B 2788434c5a24679e345fa8bde0e5a77332d9a0e640388e6e4361aedc37d0f1ee26db7d0f79775f290b9423283fb6b587fea1b1ab03ab7c0f3fcc80850b234d03 SHA512 fb34b68887425831b0e34426334db19c7906aa8c4f5161a473c6a98939ad5e4883dc76c5f2f2bea37f30b3b6abb057b182535386ca13804f6733430c5bbacc51
diff --git a/dev-python/pycuda/pycuda-2022.2.2.ebuild b/dev-python/pycuda/pycuda-2022.2.2.ebuild
deleted file mode 100644
index f4343e6daa31..000000000000
--- a/dev-python/pycuda/pycuda-2022.2.2.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-inherit cuda distutils-r1 pypi
-
-DESCRIPTION="Python wrapper for NVIDIA CUDA"
-HOMEPAGE="https://mathema.tician.de/software/pycuda/ https://pypi.org/project/pycuda/ https://github.com/inducer/pycuda"
-
-LICENSE="Apache-2.0 MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples opengl test"
-
-RDEPEND="
- dev-libs/boost:=[python,${PYTHON_USEDEP}]
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/pytools[${PYTHON_USEDEP}]
- dev-util/nvidia-cuda-toolkit[profiler]
- x11-drivers/nvidia-drivers
- opengl? ( virtual/opengl )
-"
-DEPEND="${RDEPEND}"
-
-# We need write acccess /dev/nvidia0 and /dev/nvidiactl and the portage
-# user is (usually) not in the video group
-RESTRICT="test? ( userpriv ) !test? ( test )"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- cuda_sanitize
-
- sed "s|\"--preprocess\"|&,\"--compiler-bindir=$(cuda_gccdir)\"|" \
- -i pycuda/compiler.py || die
-
- > siteconf.py || die
-
- distutils-r1_src_prepare
-}
-
-python_configure() {
- mkdir -p "${BUILD_DIR}" || die
- cd "${BUILD_DIR}" || die
-
- local conf=(
- "${EPYTHON}" "${S}"/configure.py
- --boost-inc-dir="${ESYSROOT}"/usr/include
- --boost-lib-dir="${ESYSROOT}"/usr/$(get_libdir)
- --boost-python-libname=boost_${EPYTHON/./}.so
- --boost-thread-libname=boost_thread
- --cuda-inc-dir="${ESYSROOT}"/opt/cuda/include
- --cuda-root="${ESYSROOT}"/opt/cuda
- --cudadrv-lib-dir="${ESYSROOT}"/usr/$(get_libdir)
- --cudart-lib-dir="${ESYSROOT}"/opt/cuda/$(get_libdir)
- --no-use-shipped-boost
- $(usev opengl --cuda-enable-gl)
- )
- echo ${conf[*]}
- "${conf[@]}" || die
-}
-
-python_test() {
- # we need write access to this to run the tests
- addwrite /dev/nvidia0
- addwrite /dev/nvidiactl
- addwrite /dev/nvidia-uvm
- addwrite /dev/nvidia-uvm-tools
-
- EPYTEST_DESELECT=(
- # needs investigation, perhaps failure is hardware-specific
- test/test_driver.py::test_pass_cai_array
- test/test_driver.py::test_pointer_holder_base
- )
-
- cd "${T}" || die
- epytest "${S}"/test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}