summaryrefslogtreecommitdiff
path: root/dev-python/pydantic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-30 08:16:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-30 08:16:57 +0000
commita21eae5570ee23ff259ccee6adc402fa27578a83 (patch)
tree0507ed3791ad67e98a33cc87b0a485409d6b3e77 /dev-python/pydantic
parentb7cf34e541f10778605d8740e2690d8459908ac5 (diff)
gentoo auto-resync : 30:12:2022 - 08:16:57
Diffstat (limited to 'dev-python/pydantic')
-rw-r--r--dev-python/pydantic/Manifest2
-rw-r--r--dev-python/pydantic/pydantic-1.10.3.ebuild82
2 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index a835532131e7..2c0af2f88350 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,3 +1,5 @@
DIST pydantic-1.10.2.gh.tar.gz 888288 BLAKE2B 9aac69ace185ccc56255cf36f9af472caf4c6bcbdcbb81eec66353f755673e9a240e7713c0a2ecff00a02e07b0069e4b3f1edda41f345698a979b79dd54b354a SHA512 dc2acfb271cd62b6de08bbaa48dbc76ec8d3a3f3142778ffa2cb9a2a1cad62dbdb3c7470a50e9a2825837b65a48c6aefb8736411f32c398aa9ca779841b53ac5
+DIST pydantic-1.10.3.gh.tar.gz 898768 BLAKE2B e8cec71f0d3f66e2c71e421505f624f7e92827f8fe4ef3a7c637b4f2cbc543d43e63739f8fed1a84246458d6675f19de9f83c7fc2a1d8f6e9fb18807ad5ace6f SHA512 7c9db4a010f14ab41b0e7782e59e51caded5de31798e4dd83e01037e3365e34537b30c79c12a6451fdee875e1bfe1a3d981cae58aa373917f71489231df2e6a6
EBUILD pydantic-1.10.2.ebuild 2051 BLAKE2B e604c2f97eb44b3831cbc38286f9d7772c6fefec8fecfa704f634932e0cbfdf4636820f4f56666138ff84f208e4a83d3baf91f8c2def4dc383f73b125bcc9cf6 SHA512 794200edec67fa333ac403f3a504494f2e8a55295d1ff74ac360b70614db192852044b29bf2075a56143cc323303f87c7993b3df8946d4a66eaef2d7eaf303f1
+EBUILD pydantic-1.10.3.ebuild 2131 BLAKE2B 9cc5abeaa24167397e194ffe104fdf442adefe5664080764ac43f0ed02f819409b354378d1ab7477711dfb6788ece010820d470a9e00f7479a4867487844112e SHA512 61a67313323f0899636db89a48f9082f32225620820f94bc09e2e086a1738521b096e4328684773ffd87e0a2acf6d64fea7ac2c04ae14f74d7840ca4e532a548
MISC metadata.xml 571 BLAKE2B 11d9b5831b90a37433b357349ad2fd9b0e908e054f849fee2cc16071c57b8d2d465c70275247f81d605a689ab16edaa160be3d802eaa00f3ecea4b884a5d18a1 SHA512 3f34f3708ad8fa0014f5f8ca4988225e03bb707a5ab91e295946fc480dc56eff04cff1746605e3ce1b33f9c5f94f390a74aeeb49f0d8fc5e8801bb85714117e6
diff --git a/dev-python/pydantic/pydantic-1.10.3.ebuild b/dev-python/pydantic/pydantic-1.10.3.ebuild
new file mode 100644
index 000000000000..6f11c38ea2f5
--- /dev/null
+++ b/dev-python/pydantic/pydantic-1.10.3.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_beta/b}
+DESCRIPTION="Data parsing and validation using Python type hints"
+HOMEPAGE="
+ https://github.com/pydantic/pydantic/
+ https://pypi.org/project/pydantic/
+"
+SRC_URI="
+ https://github.com/pydantic/pydantic/archive/v${PV/_beta/b}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+native-extensions"
+
+RDEPEND="
+ >=dev-python/typing-extensions-4.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ native-extensions? (
+ dev-python/cython[${PYTHON_USEDEP}]
+ )
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/python-email-validator-1.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/CFLAGS/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ if [[ ${EPYTHON} == pypy3 ]] || ! use native-extensions; then
+ # do not build extensions on PyPy to workaround
+ # https://github.com/cython/cython/issues/4763
+ local -x SKIP_CYTHON=1
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock
+
+ local EPYTEST_DESELECT=(
+ # flaky test, known upstream
+ tests/test_hypothesis_plugin.py::test_can_construct_models_with_all_fields
+ # mypy linting causes regressions with new mypy versions
+ tests/mypy
+ )
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ tests/test_private_attributes.py::test_private_attribute
+ tests/test_private_attributes.py::test_private_attribute_annotation
+ tests/test_private_attributes.py::test_private_attribute_factory
+ tests/test_private_attributes.py::test_private_attribute_multiple_inheritance
+ tests/test_private_attributes.py::test_underscore_attrs_are_private
+ )
+ ;;
+ esac
+ rm -rf pydantic || die
+ epytest
+}