summaryrefslogtreecommitdiff
path: root/dev-python/pydevd/pydevd-2.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
commit342922f04a58a969ff23806acc427c7ff79119ce (patch)
tree7c491f1183b65ff952aefc31909ea49a54196be0 /dev-python/pydevd/pydevd-2.10.0.ebuild
parent27f59f8e16510831cc751de1406f71afbf464653 (diff)
gentoo auto-resync : 24:10:2023 - 20:44:11
Diffstat (limited to 'dev-python/pydevd/pydevd-2.10.0.ebuild')
-rw-r--r--dev-python/pydevd/pydevd-2.10.0.ebuild14
1 files changed, 13 insertions, 1 deletions
diff --git a/dev-python/pydevd/pydevd-2.10.0.ebuild b/dev-python/pydevd/pydevd-2.10.0.ebuild
index cf8e60163511..39f771c76b73 100644
--- a/dev-python/pydevd/pydevd-2.10.0.ebuild
+++ b/dev-python/pydevd/pydevd-2.10.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 multiprocessing toolchain-funcs
@@ -105,6 +105,18 @@ python_test() {
tests_python/test_debugger_json.py::test_pandas
)
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests_python/test_debugger_json.py::test_case_stop_async_iteration_exception
+ 'tests_python/test_debugger.py::test_case_handled_and_unhandled_exception_generator[False-_debugger_case_unhandled_exceptions_listcomp.py]'
+ 'tests_python/test_debugger_json.py::test_case_unhandled_exception_generator[_debugger_case_unhandled_exceptions_listcomp.py]'
+ tests_python/test_debugger.py::test_case_13
+ tests_python/test_debugger_json.py::test_function_breakpoints_async
+ )
+ ;;
+ esac
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# this is only used to compare against getpid() to detect that xdist
# is being used