summaryrefslogtreecommitdiff
path: root/dev-python/pydevd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/pydevd
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest4
-rw-r--r--dev-python/pydevd/pydevd-2.6.0.ebuild88
-rw-r--r--dev-python/pydevd/pydevd-2.7.0.ebuild2
3 files changed, 2 insertions, 92 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index 174388e0d08a..3c12358736b1 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1,5 +1,3 @@
-DIST pydev_debugger_2_6_0.tar.gz 4142790 BLAKE2B 46776e261e77a745867423488f97c6584c9497d883d8e2b19f4f82c58472f410f1b5f287ce24b8c20e9cdaa2202cbc78235ea4a7e9aa2981aa520e0b58e4fcd3 SHA512 5e7703f2eec53fe7b4d78d59894cfbb14a35a62ad20431242477f66e72344d88d5538ebe2007526e4ff250e8bcf41702acc71692239693dd9cb788ced70d7aaa
DIST pydev_debugger_2_7_0.tar.gz 4154343 BLAKE2B 6504ffa5eee5548a6aa9e59712b6c0054b69c2e0f6ff48059ed8b2e3edb92ec92ea4e7f9ff084419b46310c4d08f11008571cbf70ccc4efddd0fae688e4110f5 SHA512 8f09b446eeaace1f9ecd3d331813e8bd7d8e09e1fe9dc9fa955ecc26a97ac6015f7becc4005a87405d1154280ec10eb7fa87914bcd41f27e51d90ad3eb99f643
-EBUILD pydevd-2.6.0.ebuild 2495 BLAKE2B 39b1574a0c6628f0c74b0e19d5df3d9011c0a1afb1d90a595f79ddddf1f80ca16417b751a11a0047812b37c7ee393bb93a690fcee16d9461b86a7f7e0d5cbc33 SHA512 37d05fde51b263f6bb3ede61553e08db751185d97a660c0318abf20ce1c9944d97796fd48dbfd078ed093237d882dbf4f30e9844481770941bfe75911ba3885a
-EBUILD pydevd-2.7.0.ebuild 2494 BLAKE2B 39c09b1aca12ce72821eed5ea54e5ce66de8294c07eeb806ede4327e3e61205b0e9947750c2f3e00a0fdf22cfa37fed79c4c6e90e462457e5b31c725fd9075c8 SHA512 c11c56b7c875c430f52a3ecb54408784b99200e6f878a519c4c006b6a87451dfcf18f90f3499f7a624d4ed8b3d52fbd1354dbb2f391be330a56545e324993851
+EBUILD pydevd-2.7.0.ebuild 2507 BLAKE2B 8544a8a0c6f3140eb4e688983b6edf536de0d8104e098453c8d7fc3591ffa09044a63a57adc779b5d5a085d57d5cfb5b09018b0ff8403621054e31c6ba210e06 SHA512 3958757bbfb6541f55ebb0b601ef79d531569296a3f2afbe3923484c3ba9a0184bac758ea4ac87b6b8e210ced81679b1de1d0a3ee16109ae0fc23b331da30c58
MISC metadata.xml 384 BLAKE2B 37a4caa01a28f98ec8d141129c08754e6ba4dee5910a81c26f3eafcd7ac832962e91d3e39783e4859ac7e5ae5754837c89e496c4c2c205d12626359adf7dddae SHA512 5cf80b2e0eaf21e900c83341e9bef5c74a36d3c0a7354e3b6a832184cc60c42eeef6a22236e4fd9d484dc8834e5d4f98facd2578c223da2cc187dd76f91db764
diff --git a/dev-python/pydevd/pydevd-2.6.0.ebuild b/dev-python/pydevd/pydevd-2.6.0.ebuild
deleted file mode 100644
index 2682f0672a48..000000000000
--- a/dev-python/pydevd/pydevd-2.6.0.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 toolchain-funcs
-
-MY_P="pydev_debugger_${PV//./_}"
-
-DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
-HOMEPAGE="https://github.com/fabioz/PyDev.Debugger/"
-SRC_URI="https://github.com/fabioz/PyDev.Debugger/archive/${MY_P}.tar.gz"
-S="${WORKDIR}/PyDev.Debugger-${MY_P}"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
-
-# After removing and recompiling the prebuilt lib the tests fail?
-# For some reason the test suite is executing a slightly different gdb command
-# then before, which is lacking the file name of the lib that was pre built:
-# gdb: No symbol table is loaded. Use the "file" command
-# This also happens outside of portage so it is not related to any *FLAGS
-RESTRICT="test"
-
-BDEPEND="
- test? (
- dev-python/untangle[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-# Block against the version of debugpy that still bundles pydevd
-RDEPEND="
- !<dev-python/debugpy-1.4.2
- sys-devel/gdb
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # Drop -O3 and -flto compiler args
- sed -i \
- -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
- -e '/extra_compile_args/d' \
- setup.py || die
-
- # Clean up some prebuilt files
- rm -r third_party || die
- cd pydevd_attach_to_process || die
-
- # Remove these Windows files
- rm attach_{amd64,x86}.dll || die
- rm inject_dll_{amd64,x86}.exe || die
- rm run_code_on_dllmain_{amd64,x86}.dll || die
- rm -r windows winappdbg || die
-
- # Remove these MacOS files
- rm attach_x86_64.dylib || die
-
- # Remove these prebuilt linux files
- rm attach_linux_{amd64,x86}.so || die
-
- cd linux_and_mac || die
- rm compile_mac.sh || die
-}
-
-src_compile() {
- pushd pydevd_attach_to_process/linux_and_mac || die
- # recompile removed file (extracted from compile_linux.sh)
- $(tc-getBUILD_CXX) ${CXXFLAGS} ${CFLAGS} -o "attach_linux_${ARCH}.so" \
- -ldl ${LDFLAGS} -nostartfiles attach.cpp || die
- mv "attach_linux_${ARCH}.so" ../ || die
- popd || die
- python_foreach_impl distutils-r1_python_compile
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Remove this duplicate that is installed directly to /usr/
- # These files are also correctly installed to the python site-packages dir
- rm -r "${ED}/usr/pydevd_attach_to_process" || die
-}
diff --git a/dev-python/pydevd/pydevd-2.7.0.ebuild b/dev-python/pydevd/pydevd-2.7.0.ebuild
index b8d2a6050292..a847f15b0833 100644
--- a/dev-python/pydevd/pydevd-2.7.0.ebuild
+++ b/dev-python/pydevd/pydevd-2.7.0.ebuild
@@ -16,7 +16,7 @@ S="${WORKDIR}/PyDev.Debugger-${MY_P}"
LICENSE="EPL-1.0"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv sparc x86"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86"
# After removing and recompiling the prebuilt lib the tests fail?
# For some reason the test suite is executing a slightly different gdb command