summaryrefslogtreecommitdiff
path: root/dev-python/pydevd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-29 03:04:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-10-29 03:04:53 +0000
commitbd35a61d88b111f25f4b10126e0d4755545fc7a5 (patch)
tree656ac661ed7b28ad66ba778b74bc5fe4e2b86b10 /dev-python/pydevd
parent5d4291ee2ba8b85e8515b5f47b814a5c872eed04 (diff)
gentoo auto-resync : 29:10:2024 - 03:04:53
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest2
-rw-r--r--dev-python/pydevd/pydevd-3.2.2.ebuild142
2 files changed, 144 insertions, 0 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index 91e358f40c4e..f738d7332151 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1,3 +1,5 @@
DIST PyDev.Debugger-pydev_debugger_3_1_0.gh.tar.gz 4293466 BLAKE2B 2b820b44a37362dfe554f60f418ce6c94cfd9fb9b14b6d6f521e7bd2023f044129b440878a136d67249096ba8a4aa61bb465551c1d9930989ffe9fe40c68f464 SHA512 8afaab2a69cb6785c5453ce1034a70fa28ab33c3122c1e21c485d9023317785524144c76e87864a695fa1fd26b05bc6d828db22a7cbcf025bd8aafe0b9ed4d3b
+DIST PyDev.Debugger-pydev_debugger_3_2_2.gh.tar.gz 4283873 BLAKE2B 62c4a4a4677127ed7c3f0b2f63388169e01d620dd6bd986e4f24208379dcff77993d297e3647b395b6e6e262868b69533f63370c1975b8c582a52a80ce40f77d SHA512 0d2f73fbe4d3541ff3b0e24373165f92c44c28eced1ca00b618caff5f12ee579165ba16b3692d6d4d7840c36f75c5f064aabdd554bb00d39b3b896840dfdcda4
EBUILD pydevd-3.1.0-r1.ebuild 3955 BLAKE2B b343443d3a4c3285821f1d4f1ad6752cdd59ab1393aead2c787e316b315f1ae233c275178080e94562089103228226c8ca2c61f5af5a6608ed0714dad49289e5 SHA512 13a6f7e9180d2f4fb6e9f47ad01150c710a8dff572f229f1c14421c0de657d2799e5cc63518ecf525e98edb5e384279f846b2825d36aed740e8924efa0f92cf1
+EBUILD pydevd-3.2.2.ebuild 4038 BLAKE2B 57508f915033b787d06d5d823a0d43a2e663b8834b31afe0b14ad3ff4df245bd5a36384deacfd91ee6e454a6af712ed459abd78e3afaa302899b941dcddf0839 SHA512 a74ed9b66e302ac228b4422dba336677d3a2ab6517760ba03b87aa2eab5dc95782d57ebb4022b043d6f24508787969ca2333b909b61d976524f1f1cccd2edd33
MISC metadata.xml 384 BLAKE2B 37a4caa01a28f98ec8d141129c08754e6ba4dee5910a81c26f3eafcd7ac832962e91d3e39783e4859ac7e5ae5754837c89e496c4c2c205d12626359adf7dddae SHA512 5cf80b2e0eaf21e900c83341e9bef5c74a36d3c0a7354e3b6a832184cc60c42eeef6a22236e4fd9d484dc8834e5d4f98facd2578c223da2cc187dd76f91db764
diff --git a/dev-python/pydevd/pydevd-3.2.2.ebuild b/dev-python/pydevd/pydevd-3.2.2.ebuild
new file mode 100644
index 000000000000..3d8ea9dc8fdb
--- /dev/null
+++ b/dev-python/pydevd/pydevd-3.2.2.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1 toolchain-funcs
+
+TAG="pydev_debugger_${PV//./_}"
+MY_P="PyDev.Debugger-${TAG}"
+DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
+HOMEPAGE="
+ https://github.com/fabioz/PyDev.Debugger/
+ https://pypi.org/project/pydevd/
+"
+SRC_URI="
+ https://github.com/fabioz/PyDev.Debugger/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-debug/gdb
+"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ dev-python/untangle[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Drop -O3 and -flto compiler args
+ # Make extension build failures fatal
+ sed -i \
+ -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
+ -e '/extra_compile_args/d' \
+ -e '/except/a\ raise' \
+ setup.py || die
+
+ # Disable tests incompatible with new package versions
+ sed -e '/TEST_\(DJANGO\|FLASK\)/s:True:False:' \
+ -i tests_python/debug_constants.py || die
+
+ # Clean up some prebuilt files
+ rm -r third_party || die
+ cd pydevd_attach_to_process || die
+
+ # Remove these Windows files
+ rm attach_{amd64,x86}.dll || die
+ rm inject_dll_{amd64,x86}.exe || die
+ rm run_code_on_dllmain_{amd64,x86}.dll || die
+ rm -r windows winappdbg || die
+
+ # Remove these MacOS files
+ rm attach_x86_64.dylib || die
+
+ # Remove these prebuilt linux files
+ rm attach_linux_{amd64,x86}.so || die
+
+ cd linux_and_mac || die
+ rm compile_mac.sh || die
+}
+
+src_compile() {
+ pushd pydevd_attach_to_process/linux_and_mac || die
+ # recompile removed file (extracted from compile_linux.sh)
+ $(tc-getBUILD_CXX) ${CXXFLAGS} ${CPPFLAGS} \
+ -o "../attach_linux_${ARCH}.so" \
+ ${LDFLAGS} -nostartfiles attach.cpp -ldl || die
+ popd || die
+
+ distutils-r1_src_compile
+
+ # C extensions
+ rm -r _pydevd* || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ # NB: upstream seems to run tests via runfiles.py but that script
+ # is a horror and it seems broken for us anyway
+ tests_python/test_debugger.py::test_attach_to_pid_halted
+ tests_python/test_debugger.py::test_attach_to_pid_no_threads
+ 'tests_python/test_debugger.py::test_path_translation[False]'
+ tests_python/test_debugger_json.py::test_attach_to_pid
+ tests_python/test_debugger_json.py::test_case_sys_exit_multiple_exception_attach
+ tests_python/test_debugger_json.py::test_evaluate_exception_trace
+ tests_python/test_debugger_json.py::test_gui_event_loop_custom
+ tests_python/test_debugger_json.py::test_path_translation_and_source_reference
+ tests_python/test_utilities.py::test_tracing_basic
+ tests_python/test_utilities.py::test_tracing_other_threads
+ # incompatible with xdist
+ tests_python/test_utilities.py::test_find_main_thread_id
+ tests_python/test_utilities.py::test_is_main_thread
+ # numpy-2?
+ tests_python/test_debugger_json.py::test_evaluate_numpy
+ )
+
+ case ${EPYTHON} in
+ python3.11)
+ EPYTEST_DESELECT+=(
+ tests_python/test_debugger.py::test_frame_eval_limitations
+ tests_python/test_debugger.py::test_remote_debugger_threads
+ )
+ ;;
+ python3.12)
+ EPYTEST_DESELECT+=(
+ # flaky
+ tests_python/test_debugger_json.py::test_step_next_step_in_multi_threads
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # this is only used to compare against getpid() to detect that xdist
+ # is being used
+ local -x PYDEV_MAIN_PID=1
+ epytest -p rerunfailures --reruns=5
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Remove this duplicate that is installed directly to /usr/
+ # These files are also correctly installed to the python site-packages dir
+ rm -r "${ED}/usr/pydevd_attach_to_process" || die
+}