summaryrefslogtreecommitdiff
path: root/dev-python/pydevd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-16 22:05:01 +0100
commitcc4618c9ba3d974948ebf340b542d8cb01db2f55 (patch)
tree125ee67bb9e0d548771cf7b61d04bb1f0dc57687 /dev-python/pydevd
parent677b7ba5c317778df2ad7e70df94b9b7eec4adbc (diff)
gentoo resync : 16.09.2021
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest4
-rw-r--r--dev-python/pydevd/metadata.xml2
-rw-r--r--dev-python/pydevd/pydevd-2.5.0-r1.ebuild86
-rw-r--r--dev-python/pydevd/pydevd-2.5.0.ebuild53
4 files changed, 89 insertions, 56 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index 392dacdbe11e..4609ddc6eda9 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1,3 +1,3 @@
DIST pydev_debugger_2_5_0.tar.gz 4140556 BLAKE2B 8630fc35138b3bb768b8a62a2f1388a1144baa9207aec49717c3c04843a393b130dfaef3266ad8fce5a5aa3af4e25d4441b075da0aa36ec1a8716db5ba5ac56c SHA512 7ebf1a5405a376fb19fb4bab0f4874e6be273d3c095338d8a2bfad433b0ec306918b2c650bd20dc5ffd835dd01e7398da2b66607a66dad931f98764f572e0be8
-EBUILD pydevd-2.5.0.ebuild 1671 BLAKE2B 1a8d1d3d9f052f9fc9a6dd3d7b1aa4ae5173cc3f0c0bf43841ace81553faad172cd71685c747ada3c04d74e009f0ff82a90de2943cf569329b1efeb016e73699 SHA512 db2b559c93b55297491b6ed3066b5d0e7c715aa6dab76400cd6ef421633617280f984b30418d2a45dc282590578b0b6471bccecf284b059d1857b628f7084a1f
-MISC metadata.xml 383 BLAKE2B 9e19205c72d69665eb973aa1683148b5fabd3cee8b96d84c22b9335e6d41370c651c6a088c4ac5ae0f590f2bfd0ec48fc6d344dea5486b2b0288d368a3003f7f SHA512 a0b68a79685c07caf6b85847a889932814e8843413456fe5f1a469cccffabab838b6a0b7999bba087fcd3c3aee103fc6dc4f2a3519d65c8d330755496aec8e7a
+EBUILD pydevd-2.5.0-r1.ebuild 2501 BLAKE2B 65e0dafee3eeef8c4f189b435e5a824789ed6ae09190d5ff7dae6237f39215b294437cf25b227bc32568b776b789ef04a1b9786d453a8fe59a93eb192f8f81ea SHA512 7b90e5839a2264ced18b4840a93baf31c15b5b1a49559300f834a01b30bf122d55d68409dca40a514fe4fa4e6beb083430e8b80dcaee87d44571fecc0d1209e5
+MISC metadata.xml 384 BLAKE2B 37a4caa01a28f98ec8d141129c08754e6ba4dee5910a81c26f3eafcd7ac832962e91d3e39783e4859ac7e5ae5754837c89e496c4c2c205d12626359adf7dddae SHA512 5cf80b2e0eaf21e900c83341e9bef5c74a36d3c0a7354e3b6a832184cc60c42eeef6a22236e4fd9d484dc8834e5d4f98facd2578c223da2cc187dd76f91db764
diff --git a/dev-python/pydevd/metadata.xml b/dev-python/pydevd/metadata.xml
index 8ff81dffad43..6e24df0d01f8 100644
--- a/dev-python/pydevd/metadata.xml
+++ b/dev-python/pydevd/metadata.xml
@@ -1,5 +1,5 @@
<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci@gentoo.org</email>
diff --git a/dev-python/pydevd/pydevd-2.5.0-r1.ebuild b/dev-python/pydevd/pydevd-2.5.0-r1.ebuild
new file mode 100644
index 000000000000..ed72a1482018
--- /dev/null
+++ b/dev-python/pydevd/pydevd-2.5.0-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1 toolchain-funcs
+
+DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
+HOMEPAGE="https://github.com/fabioz/PyDev.Debugger/"
+SRC_URI="https://github.com/fabioz/PyDev.Debugger/archive/refs/tags/pydev_debugger_${PV//./_}.tar.gz"
+S="${WORKDIR}/PyDev.Debugger-pydev_debugger_${PV//./_}"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc"
+
+# After removing and recompiling the prebuilt lib the tests fail?
+# For some reason the test suite is executing a slightly different gdb command
+# then before, which is lacking the file name of the lib that was pre built:
+# gdb: No symbol table is loaded. Use the "file" command
+# This also happens outside of portage so it is not related to any *FLAGS
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/untangle[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+# Block against the version of debugpy that still bundles pydevd
+RDEPEND="
+ !<dev-python/debugpy-1.4.2
+ sys-devel/gdb
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Drop -O3 and -flto compiler args
+ sed -i \
+ -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
+ -e '/extra_compile_args/d' \
+ setup.py || die
+
+ # Clean up some prebuilt files
+ rm -r third_party || die
+ cd pydevd_attach_to_process || die
+
+ # Remove these Windows files
+ rm attach_{amd64,x86}.dll || die
+ rm inject_dll_{amd64,x86}.exe || die
+ rm run_code_on_dllmain_{amd64,x86}.dll || die
+ rm -r windows winappdbg || die
+
+ # Remove these MacOS files
+ rm attach_x86_64.dylib || die
+
+ # Remove these prebuilt linux files
+ rm attach_linux_{amd64,x86}.so || die
+
+ cd linux_and_mac || die
+ rm compile_mac.sh || die
+}
+
+src_compile() {
+ pushd pydevd_attach_to_process/linux_and_mac || die
+ # recompile removed file (extracted from compile_linux.sh)
+ $(tc-getBUILD_CXX) ${CXXFLAGS} ${CFLAGS} -o "attach_linux_${ARCH}.so" \
+ -ldl ${LDFLAGS} -nostartfiles attach.cpp || die
+ mv "attach_linux_${ARCH}.so" ../ || die
+ popd || die
+ python_foreach_impl distutils-r1_python_compile
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Remove this duplicate that is installed directly to /usr/
+ # These files are also correctly installed to the python site-packages dir
+ rm -r "${ED}/usr/pydevd_attach_to_process" || die
+}
diff --git a/dev-python/pydevd/pydevd-2.5.0.ebuild b/dev-python/pydevd/pydevd-2.5.0.ebuild
deleted file mode 100644
index bc1f3680e196..000000000000
--- a/dev-python/pydevd/pydevd-2.5.0.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
-HOMEPAGE="https://github.com/fabioz/PyDev.Debugger/"
-SRC_URI="https://github.com/fabioz/PyDev.Debugger/archive/refs/tags/pydev_debugger_${PV//./_}.tar.gz"
-S="${WORKDIR}/PyDev.Debugger-pydev_debugger_${PV//./_}"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-BDEPEND="test? ( dev-python/untangle[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-# These files are included pre-built in the sources
-# TODO: Investigate what this is and if/how we can compile this properly
-QA_PREBUILT="
- /usr/lib/python*/site-packages/pydevd_attach_to_process/attach_linux_*.so
-"
-
-python_prepare_all() {
- # AssertionError: TimeoutError (note: error trying to dump threads on timeout).
- # TODO: investigate and fix this
- sed -i \
- -e 's:test_case_qthread4:_&:' \
- -e 's:test_path_translation:_&:' \
- -e 's:test_asyncio_step_over_basic:_&:' \
- -e 's:test_asyncio_step_over_end_of_function:_&:' \
- -e 's:test_asyncio_step_in:_&:' \
- -e 's:test_asyncio_step_return:_&:' \
- tests_python/test_debugger.py || die
- sed -i \
- -e 's:test_evaluate_exception_trace:_&:' \
- -e 's:test_path_translation_and_source_reference:_&:' \
- tests_python/test_debugger_json.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Remove this duplicate that is installed directly to /usr/
- # These files are also correctly installed to the python site-packages dir
- rm -r "${ED}/usr/pydevd_attach_to_process"
-}