summaryrefslogtreecommitdiff
path: root/dev-python/pydispatcher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/pydispatcher
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/pydispatcher')
-rw-r--r--dev-python/pydispatcher/Manifest2
-rw-r--r--dev-python/pydispatcher/pydispatcher-2.1.2.ebuild12
2 files changed, 4 insertions, 10 deletions
diff --git a/dev-python/pydispatcher/Manifest b/dev-python/pydispatcher/Manifest
index a1d94d4d766b..c72000423027 100644
--- a/dev-python/pydispatcher/Manifest
+++ b/dev-python/pydispatcher/Manifest
@@ -1,3 +1,3 @@
DIST PyPyDispatcher-2.1.2.tar.gz 23224 BLAKE2B 881e7063e61f80ed08f2e46967c7cf7e35d9687025a55d9b446e034085a09627b75263519c16ac64e0cbd9f84e822095f89ecbc52e95ed23a65fcb50d4e90d52 SHA512 a8a94a68551e72da2703a4f7fc93296fbffe78518ff363930125874a2a65dbbe4fe9434e910e0d019fb653785e41d024fe2c9d5bab5072c3989dd2a61ffcb708
-EBUILD pydispatcher-2.1.2.ebuild 876 BLAKE2B d66274296431e3df34c8df3bb4989a0f916e1e54f5af6adac3be33766cebc15ee5a0f2d75b3901be0167e05601f19f7a99fb54d0ea6ce23eec1c7aaa711ff266 SHA512 031c827589240b0ddbcc0c2b72e88a010c37921b2c33b185a0de360cb8c4acf692569309392af0966122afc0b46176d11ad7d57af6d1ab212497b7d0229de0d2
+EBUILD pydispatcher-2.1.2.ebuild 756 BLAKE2B 98d8cf81021f3610a7e591e01e2eadee03188993cbc87e79e4c7a6b7c69e1e4c019b175519fa95f06cb7f24f7a4ad064edc02311fb4e9d76ab13851958e07fde SHA512 a8ac5d255320668d489839d4b5dc40662c3f541a5812b0e5f1b2287a00cfee42e575b56f3dd4f0cd5e614fd8c93f694a8761d5b21f9d99a12c486ca9615e65fa
MISC metadata.xml 541 BLAKE2B bc7fa8bff7f371707fde69ad7d027f569dab8f3efd8838f9cb3ec19551beaebfe6508ddb5cc7f84f66e919323d18038fb1ef98c0f92da1f090fa5a1170441801 SHA512 7ce92eaf53bd85e61e51e88727974b9c0c473cdc4fb5a427c7997576499592bef3d6a0ac97d210d1a8f99c7252fa9e1e9219291475b5fd4e6dd21d44a072d515
diff --git a/dev-python/pydispatcher/pydispatcher-2.1.2.ebuild b/dev-python/pydispatcher/pydispatcher-2.1.2.ebuild
index e74f7a264c95..9c71fc360304 100644
--- a/dev-python/pydispatcher/pydispatcher-2.1.2.ebuild
+++ b/dev-python/pydispatcher/pydispatcher-2.1.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -10,16 +10,14 @@ MY_P="PyPyDispatcher-${PV}"
DESCRIPTION="Multi-producer-multi-consumer signal dispatching mechanism"
HOMEPAGE="https://github.com/scrapy/pypydispatcher https://pypi.org/project/PyPyDispatcher/"
SRC_URI="mirror://pypi/${MY_P::1}/${MY_P%-*}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
IUSE="doc"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-S=${WORKDIR}/${MY_P}
+distutils_enable_tests unittest
python_compile_all() {
if use doc; then
@@ -28,10 +26,6 @@ python_compile_all() {
fi
}
-python_test() {
- "${EPYTHON}" -m unittest discover -v || die "Tests fail for ${EPYTHON}"
-}
-
python_install_all() {
use doc && local HTML_DOCS=( docs/pydoc/. )
distutils-r1_python_install_all