summaryrefslogtreecommitdiff
path: root/dev-python/pydocstyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pydocstyle
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pydocstyle')
-rw-r--r--dev-python/pydocstyle/Manifest2
-rw-r--r--dev-python/pydocstyle/pydocstyle-6.1.1-r1.ebuild (renamed from dev-python/pydocstyle/pydocstyle-6.1.1.ebuild)29
2 files changed, 22 insertions, 9 deletions
diff --git a/dev-python/pydocstyle/Manifest b/dev-python/pydocstyle/Manifest
index af3de6ee94b1..4edf24c1d7f3 100644
--- a/dev-python/pydocstyle/Manifest
+++ b/dev-python/pydocstyle/Manifest
@@ -1,4 +1,4 @@
AUX pydocstyle-6.1.1-disarm-pip-install.patch 1001 BLAKE2B d82d9b358cdd6b517cf64f5b620e767342ba6230ebda715e039be2b5bdbef639ad5d0e715f033658887bede3ee330da79f2a6ca3e1a597466f3bbffdd617d371 SHA512 434a576cad8fe6a2c8086893982887306ad6b4797c1ed0c3682782a3a9ec1109fc48d94ad469cd11128232d773d5beaef2cfc1c9a68c0386581e4864d43371fa
DIST pydocstyle-6.1.1.tar.gz 73982 BLAKE2B 6a896221fdcd257f0475472e1cf87ef892d8292a4c0faf661595adb17e2d18f4a8277cda498197309d34597c448203856c272256277a7e35fba20e2e5ba47f2b SHA512 ce4932a6601c80d05a46600f5af7df54798025a5f3dc41ab8cf1bc0d63e7f78b70cccb17dc99ddab25eda9abd639f91468fca1b1ceb4539708350212e481a156
-EBUILD pydocstyle-6.1.1.ebuild 826 BLAKE2B 6a4d74175b15feba62476f4b2eec62c5bb89e041a956c26ebe7c1c976a1dbc757acfc355fdeefa0f24eabd3df95ff2bf254d840a74bf3efd75e55ebc120164f5 SHA512 dafc7bd9640ce64d52f5f11cea60da974a2fa23d7ea88d985bf9bce6f676f324a893857e79d1e54a2b690579b41213eb8f44ed745f4d556e50ce408f9c130474
+EBUILD pydocstyle-6.1.1-r1.ebuild 907 BLAKE2B 57f32b8f5e4ec34f8bda21894780e698a054bdc5550e8adadc7acdcb36d7ac95ee369214b0d2c5900242e8d61bfae7b44de3840b8a59338ebe86df27b891751c SHA512 0073f98c21a90b393de547bb7116041fd20d04eeeb0246059a14dad6ebfa17718acfdc7d895083b772f53df3f79b3fdaf19d76a48acd0df295d66bc5b48b3e34
MISC metadata.xml 665 BLAKE2B ac358d1ac5d68d11710048ccd4050f45cee96788829ee806bc5f4364c0f6b03707dcf15dd0cb9e7e3870cd9feebcead3c44b8f6bbff6738aa593079685c2a3c0 SHA512 7642d1384de3ec4bd55f7afc69ce67ad018eb9294f104234c5f3eb23a2c7a5ab36bda890a440fb5a7af8045d215048caf4b15bb3d965f414b755b51a269337cc
diff --git a/dev-python/pydocstyle/pydocstyle-6.1.1.ebuild b/dev-python/pydocstyle/pydocstyle-6.1.1-r1.ebuild
index 3216381e7135..e3d4a9f3dd1b 100644
--- a/dev-python/pydocstyle/pydocstyle-6.1.1.ebuild
+++ b/dev-python/pydocstyle/pydocstyle-6.1.1-r1.ebuild
@@ -1,24 +1,37 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Python docstring style checker"
-HOMEPAGE="https://github.com/PyCQA/pydocstyle/"
-SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/PyCQA/pydocstyle/
+ https://pypi.org/project/pydocstyle/
+"
+SRC_URI="
+ https://github.com/PyCQA/pydocstyle/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-RDEPEND="dev-python/snowballstemmer[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/snowballstemmer[${PYTHON_USEDEP}]
+"
BDEPEND="
- test? ( dev-python/toml[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/toml[${PYTHON_USEDEP}]
+ )
+"
-distutils_enable_tests --install pytest
+distutils_enable_tests pytest
# Requires network to lookup github issues
#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker