summaryrefslogtreecommitdiff
path: root/dev-python/pydvdread/pydvdread-1.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pydvdread/pydvdread-1.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pydvdread/pydvdread-1.0-r1.ebuild')
-rw-r--r--dev-python/pydvdread/pydvdread-1.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pydvdread/pydvdread-1.0-r1.ebuild b/dev-python/pydvdread/pydvdread-1.0-r1.ebuild
new file mode 100644
index 000000000000..30b1b500bd16
--- /dev/null
+++ b/dev-python/pydvdread/pydvdread-1.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A set of Python bindings for the libdvdread library"
+HOMEPAGE="http://pydvdread.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+RESTRICT="test" # Requires an actual DVD to test.
+
+DEPEND="media-libs/libdvdread
+ dev-lang/swig"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-py3k.patch \
+ "${FILESDIR}"/${P}-api-update.patch )
+
+python_test() {
+ "${PYTHON}" tests/TestAll.py || die "Tests fail with ${EPYTHON}"
+}