summaryrefslogtreecommitdiff
path: root/dev-python/pydyf/pydyf-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-19 23:22:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-19 23:22:40 +0100
commit4ae4e74a3a13c7c5aaebf61e650538b005204fcb (patch)
tree4abb4271a26b735b28a4eb8b69206cbcc8e7b4e2 /dev-python/pydyf/pydyf-0.3.0.ebuild
parentb2a3508c3634488d32ec5bbe6b4365ab27185ebd (diff)
gentoo auto-resync : 19:09:2022 - 23:22:40
Diffstat (limited to 'dev-python/pydyf/pydyf-0.3.0.ebuild')
-rw-r--r--dev-python/pydyf/pydyf-0.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pydyf/pydyf-0.3.0.ebuild b/dev-python/pydyf/pydyf-0.3.0.ebuild
new file mode 100644
index 000000000000..a010a449bc5f
--- /dev/null
+++ b/dev-python/pydyf/pydyf-0.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A low-level PDF generator"
+HOMEPAGE="
+ https://pypi.org/project/pydyf/
+ https://github.com/CourtBouillon/pydyf/
+"
+SRC_URI="
+ https://github.com/CourtBouillon/pydyf/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ app-text/ghostscript-gpl
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e '/addopts/d' -i pyproject.toml || die
+ distutils-r1_src_prepare
+}