summaryrefslogtreecommitdiff
path: root/dev-python/pyenchant/pyenchant-3.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/pyenchant/pyenchant-3.2.2.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/pyenchant/pyenchant-3.2.2.ebuild')
-rw-r--r--dev-python/pyenchant/pyenchant-3.2.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyenchant/pyenchant-3.2.2.ebuild b/dev-python/pyenchant/pyenchant-3.2.2.ebuild
new file mode 100644
index 000000000000..6af05a8eb115
--- /dev/null
+++ b/dev-python/pyenchant/pyenchant-3.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the Enchant spellchecking system"
+HOMEPAGE="https://github.com/pyenchant/pyenchant
+ https://pypi.org/project/pyenchant/"
+SRC_URI="
+ https://github.com/pyenchant/pyenchant/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="app-text/enchant:*"
+BDEPEND="
+ test? (
+ app-dicts/myspell-en
+ )"
+
+distutils_enable_tests pytest