summaryrefslogtreecommitdiff
path: root/dev-python/pyfakefs/pyfakefs-5.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-10 13:34:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-10 13:34:01 +0100
commitbba7ed73af4fe3b333cb970dc40a9098e2d1c54b (patch)
tree4a2377c9096a6e85935bc1b24a50c09537fbb3ca /dev-python/pyfakefs/pyfakefs-5.0.0.ebuild
parentf69024d0d689548234c6173dc2d8a5bb466b0525 (diff)
gentoo auto-resync : 10:10:2022 - 13:34:00
Diffstat (limited to 'dev-python/pyfakefs/pyfakefs-5.0.0.ebuild')
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/pyfakefs-5.0.0.ebuild b/dev-python/pyfakefs/pyfakefs-5.0.0.ebuild
new file mode 100644
index 000000000000..54098f2af2c1
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/jmcgeheeiv/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}