summaryrefslogtreecommitdiff
path: root/dev-python/pyftpdlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-25 00:12:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-25 00:12:20 +0100
commit996a2bda06cb164877d5d952774a6db1b271c2f3 (patch)
tree31930352b48fc7622d658ae37658c57ad9511ef6 /dev-python/pyftpdlib
parent67e5603b2844a6657dd0438fa26626b013e5567f (diff)
gentoo auto-resync : 25:06:2024 - 00:12:20
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/Manifest2
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.10.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index e0ef211686a0..f62b0f3ba24b 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1,3 +1,5 @@
+DIST pyftpdlib-1.5.10.tar.gz 204487 BLAKE2B 7c611498dc2d11f752bf6a0ada01d906fca5c28e93b21bbcaaa76fafc88dcfe7afe616eb06f102123e614e061db2b6b62766f5036d749f8bd2b6d5cc35fc52e8 SHA512 c8c28d7aab13f2aab222ae038bde96f17abefd461830813ca00b621a6ee3e809c59ed135149ba735e7e92a6722aecfaf7095ccbacd7b3e17a16ee69fe1668766
DIST pyftpdlib-1.5.9.tar.gz 204755 BLAKE2B f96e670a37023489a3f70f28d7e489633031f4c8dd34e6ece04a13a36a5de60f216dc267a80650c3f315a6a83081b1afc1b470c75ca18af5a80729a7ac363b98 SHA512 3efa07f5522cee89d2bf60c93b1315dfb149da622f34e043aca0ac1c4336c0a0885d7238123068401afa6988da9cbde6adfac78f08918d3a14e84c17ebb8b32f
+EBUILD pyftpdlib-1.5.10.ebuild 1468 BLAKE2B 6d1099035c1f1a66135c68960315f44705a1ade0f11d7e0791ef20d645e8f85ee63a60e7b5648de2e46311971441332632337112a11326c704f98e4ed3e25f84 SHA512 e8f5ba7440a0d7ec1064dfa91ae8f9b70cb404822ca1ea7b32a0a23105c1a76335845ea85d963e6d5b01f15b89eddcf9fb12564c3a4b2040668ad29276d439ce
EBUILD pyftpdlib-1.5.9.ebuild 1461 BLAKE2B 5959b6d5674617857d8f7f66e5010cc9fba123e3bb3c4d01d3b81ee1101dee1c534b56138cc58a44799ae12d903a5f81b2ae8506301ad241be484ef2371c2ea0 SHA512 80f23999152160d759eb71d52d6c646d0e3b69acc0272ad76c1e52eb96201a0256ef9c25e09bea1fce786870647f56cdf3e743515e0e1036f6da12cab1052777
MISC metadata.xml 463 BLAKE2B ad4e4d5a1717e55743061f2cb4baaa7ea8ce73f4caf0c8d62535aaf73daf12339584bf75c82c35b425223f478094bb37518b43d34694fb4bc6aef6f11033fa8e SHA512 98bb4e647da164a8676f9162d1109d1f6d1ff9279ba8d26207f2ed793537af27de11b40296bacfb478e87b6479c9d31bb24f56bc1acf2a0bc228b2d00a733e1d
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.10.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.10.ebuild
new file mode 100644
index 000000000000..dd007e5da5cb
--- /dev/null
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.10.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python FTP server library"
+HOMEPAGE="
+ https://github.com/giampaolo/pyftpdlib/
+ https://pypi.org/project/pyftpdlib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples ssl"
+
+RDEPEND="
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_test() {
+ rm -rf pyftpdlib || die
+ # Some of these tests tend to fail
+ local EPYTEST_DESELECT=(
+ # fail because they process sys.argv and expect program args
+ # rather than pytest args, sigh
+ test/test_misc.py
+ # TODO
+ test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
+ )
+ # Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
+ local -x TZ=UTC+1
+ # Skips some shoddy tests plus increases timeouts
+ local -x TRAVIS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs pyftpdlib
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}