summaryrefslogtreecommitdiff
path: root/dev-python/pyftpdlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pyftpdlib
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/Manifest2
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild (renamed from dev-python/pyftpdlib/pyftpdlib-1.5.6.ebuild)22
2 files changed, 7 insertions, 17 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index 16a37c1a5f89..3b9296e1678b 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1,3 +1,3 @@
DIST pyftpdlib-1.5.6.tar.gz 188099 BLAKE2B 508e94da6b27b4b1f15306df2916c176f07ca31944398e9ac580fca8d2cdc72ca0ee8e7db282de6745e2e401b23b1fa8cb8de400dc2ba998b93ac45772c78157 SHA512 a3c3c1cac221a8a3c090ee208c03134bb1b8de58099a23ca6ee422f06fb97a0ed561c96e62c62b21fa112dd0b3458651b9fc0c55d72dc0bed79d0583b319a50d
-EBUILD pyftpdlib-1.5.6.ebuild 3087 BLAKE2B 59afa5e6d8c19a08011642bf1e2c3ec4226e95d9e9a579f577470a2bd829f01a0e806f786989ee317f93dd69730866122703d63112fd74b529a8f9aa042b5703 SHA512 85a508dc09f2b4050fac49d473e1027671a8d60b24e6f7a33d5b85fd247d8d59dd279fbf5d0f5aab47eb7ba10242fad01894a22619dbb73dec578872618a5c05
+EBUILD pyftpdlib-1.5.6-r1.ebuild 2732 BLAKE2B 3e88a21fb6c968d686c587b36eb2642a038beaa9f76210042a7368a07ff51a3f8291877f12ea716c2c1b1c53d9c9c248b1f212c07967b085bbcc6b2178b4775a SHA512 cdc40c132a64002a8d112c400180479ce436f9609e43c4ca8e70c1cc51221b363bdcf43efeb76036ca3dea5d45d3d8925cb383709eb0a643f63c54f8b48dafef
MISC metadata.xml 438 BLAKE2B 0e0860eb9d885ec9b432b504bef6a9394cf4a2d6d99751c80fec8441d8910f8a17364e5f32782638ac689abf5cdd3ebcb5fa20e7da3d612a5e8844e8c8a34d76 SHA512 a748827370b53c94fed352cd6bbd7468a22c7ca2f15c4601c98a2689e3a7e652ed28434bcd125fe0f3018d5508600df03130c18d7d67834b28ac0c3480b16345
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.6.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
index ef5525f50ada..c98a11ff0494 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.6.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -19,13 +20,10 @@ RESTRICT="!test? ( test )"
RDEPEND="
ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
- dev-python/pysendfile[${PYTHON_USEDEP}]
"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+BDEPEND="
test? (
${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
@@ -40,6 +38,8 @@ python_test() {
pytest ${PN}/test/test_misc.py || die "Tests failed with ${EPYTHON}"
# Some of these tests tend to fail
local skipped_tests=(
+ # Those tests are run separately
+ pyftpdlib/test/test_misc.py
# https://github.com/giampaolo/pyftpdlib/issues/470
# https://bugs.gentoo.org/659108
pyftpdlib/test/test_functional_ssl.py::TestTimeouts::test_idle_data_timeout2
@@ -62,8 +62,7 @@ python_test() {
pyftpdlib/test/test_servers.py::TestFtpAuthentication::test_auth_failed
)
# Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
- TZ=UTC+1 pytest -vv \
- --ignore ${PN}/test/test_misc.py ${skipped_tests[@]/#/--deselect } \
+ TZ=UTC+1 pytest -vv ${skipped_tests[@]/#/--deselect } \
|| die "Tests failed with ${EPYTHON}"
}
@@ -75,12 +74,3 @@ python_install_all() {
fi
distutils-r1_python_install_all
}
-
-pkg_postinst() {
- if [[ -z ${REPLACING_VERSIONS} ]] && \
- [[ ${PYTHON_TARGETS} == *python2_7* ]] && \
- ! has_version dev-python/pysendfile ; then
- elog "dev-python/pysendfile is not installed"
- elog "It can considerably speed up file transfers for Python 2"
- fi
-}