summaryrefslogtreecommitdiff
path: root/dev-python/pyftpdlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-24 04:04:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-24 04:04:24 +0100
commite7daa1f959ba2c720f36a6984f588098e68b15cd (patch)
tree42ed099f2514ebda2681a4de13af60727c8a9fab /dev-python/pyftpdlib
parentfd93fe10d9e6c855fed8e1524b2d2d64d2085570 (diff)
gentoo auto-resync : 24:10:2024 - 04:04:24
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/Manifest2
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-2.0.1.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index 97698f63d432..e6994e36cede 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1,3 +1,5 @@
DIST pyftpdlib-2.0.0.tar.gz 196108 BLAKE2B bec261eac70a93092055413fca67dd4a480e492481f027b32508dcee8b479dbc0ec84c56d972dca63f2fbf4e3240e02b1c2877105cf77130bf75b64c9785993e SHA512 c154127771b949854c05f87a7b77f1cf144e2756cb0709c44cd0921c2ac415e7c6336c6dca1982b762087a42fc1408e26fbb2ebecbf9255d6f2d6019af14ccfe
+DIST pyftpdlib-2.0.1.tar.gz 202285 BLAKE2B 16e25d45a7d832e0a35e810d3017091e4a00b25b85cefac16182ce36e213ee09119d0705f84e3b6c92b7c7becd80c8e91245f5591dd7e88daa4944fdcc472940 SHA512 b913d2deaa9d16239eca1e00fe9b01c33222173242b1b6d5513de563cdd4a5c3bf346cbd1d6044c74b16a7691a4b619a01aff373e2f94e08f232f13e3383d99b
EBUILD pyftpdlib-2.0.0.ebuild 1584 BLAKE2B 5d6ffe50682f9604d5763e10c83ac13574a4c91ff336cde5c6ed59447adde1cfe6780b5618b055132b113c4624095d4047c81ec27cd43eced99ce89a63a450ef SHA512 e828437b31dd53707ef69ed99720e90516e988ffe0f7bd9640faf7f219aecd76636bb1f3620e87a285d17dfa28071bd25118ce42f38b1cfe4c8787f99dad6562
+EBUILD pyftpdlib-2.0.1.ebuild 1591 BLAKE2B 76471d463b60e1df91c975051cd3af8e3e86814e7ba69f1351a075a1d244558f7050d0f4bf9006bf05f2dd4d9da5367eb999cebfaea601f1a3653e18f3f0b9e9 SHA512 1e974526d415a5d6f89375537ba893e15d4507ff7930540282965d68f96df4219a24a433c270dd97fdfd228cfae7f22dcc9fc05afb2e35e3046a9323da8a88e6
MISC metadata.xml 463 BLAKE2B ad4e4d5a1717e55743061f2cb4baaa7ea8ce73f4caf0c8d62535aaf73daf12339584bf75c82c35b425223f478094bb37518b43d34694fb4bc6aef6f11033fa8e SHA512 98bb4e647da164a8676f9162d1109d1f6d1ff9279ba8d26207f2ed793537af27de11b40296bacfb478e87b6479c9d31bb24f56bc1acf2a0bc228b2d00a733e1d
diff --git a/dev-python/pyftpdlib/pyftpdlib-2.0.1.ebuild b/dev-python/pyftpdlib/pyftpdlib-2.0.1.ebuild
new file mode 100644
index 000000000000..f28406bf5316
--- /dev/null
+++ b/dev-python/pyftpdlib/pyftpdlib-2.0.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python FTP server library"
+HOMEPAGE="
+ https://github.com/giampaolo/pyftpdlib/
+ https://pypi.org/project/pyftpdlib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples ssl"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pyasynchat[${PYTHON_USEDEP}]
+ dev-python/pyasyncore[${PYTHON_USEDEP}]
+ ' 3.12 3.13)
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_test() {
+ rm -rf pyftpdlib || die
+ # Some of these tests tend to fail
+ local EPYTEST_DESELECT=(
+ # fail because they process sys.argv and expect program args
+ # rather than pytest args, sigh
+ test/test_misc.py
+ # TODO
+ test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
+ )
+ # Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
+ local -x TZ=UTC+1
+ # Skips some shoddy tests plus increases timeouts
+ local -x TRAVIS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs pyftpdlib
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}