summaryrefslogtreecommitdiff
path: root/dev-python/pygal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pygal
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pygal')
-rw-r--r--dev-python/pygal/Manifest6
-rw-r--r--dev-python/pygal/metadata.xml13
-rw-r--r--dev-python/pygal/pygal-2.1.1-r1.ebuild18
-rw-r--r--dev-python/pygal/pygal-2.1.1.ebuild18
-rw-r--r--dev-python/pygal/pygal-2.4.0.ebuild65
5 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/pygal/Manifest b/dev-python/pygal/Manifest
new file mode 100644
index 000000000000..6248e86aaa45
--- /dev/null
+++ b/dev-python/pygal/Manifest
@@ -0,0 +1,6 @@
+DIST pygal-2.1.1.tar.gz 69757 BLAKE2B d79e65c374e9d191a8e6671fd3bebfee4680c46b54ae141db74d67a08696e8bfa9ef88dcbb07ebf9e267fa5a7024b97a0c9f91f056753caf169e0518a6f49786 SHA512 79851bd6278a3a71f067ea11f273fcd0755ac0ab2ba51266b161fff1f3b49d690bc2a1b3432255da4f3cd5b9cfcff570d713d0bbfaf6f2dfe5b6f922989c72bd
+DIST pygal-2.4.0.tar.gz 4554802 BLAKE2B 9627558e734420bfb3137989d0cc1978a0a06a597d3d5d071e13653876a4bb3266f12f1a8a358076619d997998754c29ee75058356ba66da64b112a24c2cbe2a SHA512 d69fbcff3792cb0b952addc3bfbaea76628d5546482c291ef217c592a820a73a65b1eb522c5d7877e7a794d19b74636126d99a4ff280e8467ab07a95000ba823
+EBUILD pygal-2.1.1-r1.ebuild 487 BLAKE2B c2fd226428b2a13c0e0b2d2a492a5b02a7ff85c103208b5edd69dc87a9f1788c9d648d2f08987de797ed29105ad66318a3772ed0dfecd1aec04fd11ec9a7f38e SHA512 edc14a7550530cb29d528f90ad430561cb5c5459c74db0bd88a4208a2bacceaba758a85720a2475dfa0e9541ce53f1cc938e65e1c7bbb18a72176cf4f5d51889
+EBUILD pygal-2.1.1.ebuild 481 BLAKE2B ef050cec1114c73e14c289a0df95385e407790c1c67b7999be1e0f04f42ea0af8bc980bccb0819533decfc1119ec356f2ad05f57a7784bd8b40b3fcd9abe83c9 SHA512 55d66d7997e72dcdf25b77616d2c817c65e7b488d206b772d6bc8f71e259c2b19031c9011a229bf0795c22d1edf0da16f272c6ea60e988812e5d5ac040adc1bc
+EBUILD pygal-2.4.0.ebuild 1553 BLAKE2B 416a88e70b1f716aa36d48d269f1045cc560f26438388c784d209e4deec8a227d9f56f6284c715214e84bd6bbfec727fb4baafce24aa3a929c72cadf35cca470 SHA512 77a06025f87ad271f9b06a79d04d271497d8a5eefc4944383e584c965aa8d22928d3891c4f26c46d3ff29d7ff8304dcd584ee529dcbce1d4ded74b52f2a1f0f4
+MISC metadata.xml 432 BLAKE2B 935ce59a5a29aecbe4015fc52312fb03be02821a20863d20171378a68ced0aadfb43f7d1898fe52b8159cc0cd5a78ae0daedb97b730fd864de39abf3a617cd92 SHA512 1d2e68e4622a235b6df15390271b1f331b366a2ad1432740de81de20b494ccfc9e5f0e94f8b63acee67679e10267c0f21c66b58514e72f32d0fa3b5b262640d3
diff --git a/dev-python/pygal/metadata.xml b/dev-python/pygal/metadata.xml
new file mode 100644
index 000000000000..a670a65e1441
--- /dev/null
+++ b/dev-python/pygal/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pygal</remote-id>
+ <remote-id type="github">Kozea/pygal</remote-id>
+ <bugs-to>https://github.com/Kozea/pygal/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygal/pygal-2.1.1-r1.ebuild b/dev-python/pygal/pygal-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..0c6c2808c66d
--- /dev/null
+++ b/dev-python/pygal/pygal-2.1.1-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="A python SVG charts generator"
+HOMEPAGE="http://pygal.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
+ media-gfx/cairosvg[${PYTHON_USEDEP}]"
diff --git a/dev-python/pygal/pygal-2.1.1.ebuild b/dev-python/pygal/pygal-2.1.1.ebuild
new file mode 100644
index 000000000000..104826229866
--- /dev/null
+++ b/dev-python/pygal/pygal-2.1.1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="A python SVG charts generator"
+HOMEPAGE="http://pygal.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]
+ media-gfx/cairosvg[${PYTHON_USEDEP}]"
diff --git a/dev-python/pygal/pygal-2.4.0.ebuild b/dev-python/pygal/pygal-2.4.0.ebuild
new file mode 100644
index 000000000000..17ea7a3d5c38
--- /dev/null
+++ b/dev-python/pygal/pygal-2.4.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A python SVG charts generator"
+HOMEPAGE="http://pygal.org/"
+# PyPI tarballs do not contain docs
+# https://github.com/Kozea/pygal/pull/428
+SRC_URI="https://github.com/Kozea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ media-gfx/cairosvg[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+# CHANGELOG is a symlink to docs/changelog.rst
+DOCS=( docs/changelog.rst README.md )
+
+python_prepare_all() {
+ sed -i "/sphinx.ext.intersphinx/d" docs/conf.py || die
+ # Not actually required unless we want to do setup.py test
+ # https://github.com/Kozea/pygal/issues/430
+ sed -i "s/'pytest-runner'\(,\)\?//" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}