summaryrefslogtreecommitdiff
path: root/dev-python/pygal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /dev-python/pygal
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'dev-python/pygal')
-rw-r--r--dev-python/pygal/Manifest4
-rw-r--r--dev-python/pygal/metadata.xml2
-rw-r--r--dev-python/pygal/pygal-2.4.0.ebuild65
3 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/pygal/Manifest b/dev-python/pygal/Manifest
index e84aee677aef..d7337b280b52 100644
--- a/dev-python/pygal/Manifest
+++ b/dev-python/pygal/Manifest
@@ -1,4 +1,6 @@
DIST pygal-2.1.1.tar.gz 69757 BLAKE2B d79e65c374e9d191a8e6671fd3bebfee4680c46b54ae141db74d67a08696e8bfa9ef88dcbb07ebf9e267fa5a7024b97a0c9f91f056753caf169e0518a6f49786 SHA512 79851bd6278a3a71f067ea11f273fcd0755ac0ab2ba51266b161fff1f3b49d690bc2a1b3432255da4f3cd5b9cfcff570d713d0bbfaf6f2dfe5b6f922989c72bd
+DIST pygal-2.4.0.tar.gz 4554802 BLAKE2B 9627558e734420bfb3137989d0cc1978a0a06a597d3d5d071e13653876a4bb3266f12f1a8a358076619d997998754c29ee75058356ba66da64b112a24c2cbe2a SHA512 d69fbcff3792cb0b952addc3bfbaea76628d5546482c291ef217c592a820a73a65b1eb522c5d7877e7a794d19b74636126d99a4ff280e8467ab07a95000ba823
EBUILD pygal-2.1.1-r1.ebuild 487 BLAKE2B c2fd226428b2a13c0e0b2d2a492a5b02a7ff85c103208b5edd69dc87a9f1788c9d648d2f08987de797ed29105ad66318a3772ed0dfecd1aec04fd11ec9a7f38e SHA512 edc14a7550530cb29d528f90ad430561cb5c5459c74db0bd88a4208a2bacceaba758a85720a2475dfa0e9541ce53f1cc938e65e1c7bbb18a72176cf4f5d51889
EBUILD pygal-2.1.1.ebuild 481 BLAKE2B ef050cec1114c73e14c289a0df95385e407790c1c67b7999be1e0f04f42ea0af8bc980bccb0819533decfc1119ec356f2ad05f57a7784bd8b40b3fcd9abe83c9 SHA512 55d66d7997e72dcdf25b77616d2c817c65e7b488d206b772d6bc8f71e259c2b19031c9011a229bf0795c22d1edf0da16f272c6ea60e988812e5d5ac040adc1bc
-MISC metadata.xml 318 BLAKE2B 0fbdb019660f60577a4ac806d813614ea0d14e68ce7ae79ab9142fdcab862e2b800b24ad5ff20c3325a9c8084400742acd5523f2a35ecc23d78954bee29ba919 SHA512 ba609ecf46859eb8806278de9b5bf82e04ec30641b4654c4f842dc6ea8e90636e8d4bc654e84aa181711c34f4714cd1019ae31cfb0a5be0c0709aca9bc41c895
+EBUILD pygal-2.4.0.ebuild 1554 BLAKE2B c29c78dbf1535c586aeb0e56a4ebff99f684cacf735711b0119e37c7d336d73b6677a4a99849405f1a49f2c629bb638dc8ad18de39cfdbcd3f791e70bf703ca0 SHA512 9b6051e3d1b988e01ea923875038341f346d8ddfd3c66d607a6db1fb444a92f8704e0a01bfaac550ea3fbe346c5229352016ca02665c2ddf50a589efebb4c328
+MISC metadata.xml 432 BLAKE2B 935ce59a5a29aecbe4015fc52312fb03be02821a20863d20171378a68ced0aadfb43f7d1898fe52b8159cc0cd5a78ae0daedb97b730fd864de39abf3a617cd92 SHA512 1d2e68e4622a235b6df15390271b1f331b366a2ad1432740de81de20b494ccfc9e5f0e94f8b63acee67679e10267c0f21c66b58514e72f32d0fa3b5b262640d3
diff --git a/dev-python/pygal/metadata.xml b/dev-python/pygal/metadata.xml
index 3ba5ce82d6ca..a670a65e1441 100644
--- a/dev-python/pygal/metadata.xml
+++ b/dev-python/pygal/metadata.xml
@@ -7,5 +7,7 @@
</maintainer>
<upstream>
<remote-id type="pypi">pygal</remote-id>
+ <remote-id type="github">Kozea/pygal</remote-id>
+ <bugs-to>https://github.com/Kozea/pygal/issues</bugs-to>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pygal/pygal-2.4.0.ebuild b/dev-python/pygal/pygal-2.4.0.ebuild
new file mode 100644
index 000000000000..cb453601e913
--- /dev/null
+++ b/dev-python/pygal/pygal-2.4.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A python SVG charts generator"
+HOMEPAGE="http://pygal.org/"
+# PyPI tarballs do not contain docs
+# https://github.com/Kozea/pygal/pull/428
+SRC_URI="https://github.com/Kozea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ media-gfx/cairosvg[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+# CHANGELOG is a symlink to docs/changelog.rst
+DOCS=( docs/changelog.rst README.md )
+
+python_prepare_all() {
+ sed -i "/sphinx.ext.intersphinx/d" docs/conf.py || die
+ # Not actually required unless we want to do setup.py test
+ # https://github.com/Kozea/pygal/issues/430
+ sed -i "s/'pytest-runner'\(,\)\?//" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ py.test || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}